Decidim vulnerable to cross-site scripting (XSS) in the dynamic file uploads
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Decidim is a participatory democracy framework. Starting in version 0.27.0 and prior to versions 0.27.5 and 0.28.0, the dynamic file upload feature is subject to potential cross-site scripting attacks in case the attacker manages to modify the file names of the records being uploaded to the server. This appears in sections where the user controls the file upload dialogs themselves and has the technical knowledge to change the file names through the dynamic upload endpoint. Therefore I believe it would require the attacker to control the whole session of the particular user but in any case, this needs to be fixed. Successful exploit of this vulnerability would require the user to have successfully uploaded a file blob to the server with a malicious file name and then have the possibility to direct the other user to the edit page of the record where the attachment is attached. The users are able to craft the direct upload requests themselves controlling the file name that gets stored to the database. The attacker is able to change the filename e.g. to `<svg onload=alert('XSS')>` if they know how to craft these requests themselves. And then enter the returned blob ID to the form inputs manually by modifying the edit page source. Versions 0.27.5 and 0.28.0 contain a patch for this issue. As a workaround, disable dynamic uploads for the instance, e.g. from proposals.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| decidim | decidim | 0.27.0 to before 0.27.5 | 0.27.5 | Patch available | CNA |
| — | decidim (RubyGems) | 0.27.0 to before 0.27.5 | 0.27.5 | Patch available | GHSA-9w99-78rj-hmxq |
| — | decidim-core (RubyGems) | 0.27.0 to before 0.27.5 | 0.27.5 | Patch available | GHSA-9w99-78rj-hmxq |
- decidim Vendordecidim Affected 0.27.0 to before 0.27.5 Fixed in 0.27.5 Patch available CNA
- decidim (RubyGems) Vendor— Affected 0.27.0 to before 0.27.5 Fixed in 0.27.5 Patch available GHSA-9w99-78rj-hmxq
- decidim-core (RubyGems) Vendor— Affected 0.27.0 to before 0.27.5 Fixed in 0.27.5 Patch available GHSA-9w99-78rj-hmxq
Remediation
- Fix · CNA decidim (decidim) Fixed in 0.27.5
- Fix · GHSA-9w99-78rj-hmxq decidim (RubyGems) Fixed in 0.27.5 Advisory →
- Fix · GHSA-9w99-78rj-hmxq decidim-core (RubyGems) Fixed in 0.27.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-51447
- 2026-10-03 Alias added: GHSA-9w99-78rj-hmxq
References
Patch 2
Other 5
- https://github.com/decidim/decidim/pull/11612
- https://github.com/decidim/decidim/releases/tag/v0.27.5
- https://github.com/decidim/decidim/releases/tag/v0.28.0
- https://github.com/rails/rails/blob/a967d355c6fee9ad9b8bd115d43bc8b0fc207e7e/activestorage/app/controllers/active_storage/direct_uploads_controller.rb#L14
- https://github.com/decidim/decidim
More Decidim vulnerabilities
- TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
- TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
- TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
- TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
- TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
- TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
Sources
- CVE-2023-51447 · CVE Program
- CVE-2023-51447 · NVD
- FIRST EPSS
- GHSA-9w99-78rj-hmxq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences