Improper access control in themehunk Vayu Blocks – Website Builder for the Block Editor
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-284.
Summary
The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation due to a missing capability check on the tp_install() function in all versions up to, and including, 1.1.1. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated. This vulnerability was partially patched in version 1.1.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10124
- 2026-10-03 Alias added: GHSA-pw34-xq7x-mmwc
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/81e7ab80-7df2-4ef4-80ee-a11d057151c4?source=cve
- https://plugins.trac.wordpress.org/browser/vayu-blocks/trunk/inc/vayu-sites/core/class-installation.php#L29
- https://plugins.trac.wordpress.org/browser/vayu-blocks/trunk/inc/vayu-sites/app.php#L28
- https://plugins.trac.wordpress.org/browser/vayu-blocks/trunk/inc/vayu-sites/app.php#L46
- https://plugins.trac.wordpress.org/changeset/3173408/
- https://plugins.trac.wordpress.org/changeset/3203532/vayu-blocks/tags/1.2.0/inc/vayu-sites/app.php
More themehunk vulnerabilities
- TI-2024-11108 Hunk Companion < 1.9.0 - Unauthenticated Plugin Installation CVSS 3.1CRITICAL 9.8
- TI-2024-08412 Code injection in themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation CVSS 3.1CRITICAL 9.8
- TI-2024-09004 Hunk Companion <= 1.8.4 - Missing Authorization to Unauthenticated Arbitrary Plugin Installation/Activation CVSS 3.1CRITICAL 9.8
- TI-2024-03392 Responsive Contact Form Builder & Lead Generation Plugin <= 1.8.9 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2022-02219 WP Popup Builder < 1.2.9 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-09703 Lead Form Builder < 1.9.8 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-10124 · CVE Program
- CVE-2024-10124 · NVD
- FIRST EPSS
- GHSA-pw34-xq7x-mmwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences