Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2024-003
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Drupal Core allows Cross-Site Scripting (XSS).This issue affects Drupal Core: from 8.8.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 8.8.0 to before 10.2.11; 10.3.0 to before 10.3.9; 11.0.0 to before 11.0.8 | 10.2.11, 10.3.9, 11.0.8 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.8.0 to before 10.2.11 | 10.2.11 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/core (Packagist) | 10.3.0 to before 10.3.9 | 10.3.9 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/core (Packagist) | 11.0.0 to before 11.0.8 | 11.0.8 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/core-recommended (Packagist) | 8.8.0 to before 10.2.11 | 10.2.11 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/core-recommended (Packagist) | 10.3.0 to before 10.3.9 | 10.3.9 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/core-recommended (Packagist) | 11.0.0 to before 11.0.8 | 11.0.8 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/drupal (Packagist) | 8.8.0 to before 10.2.11 | 10.2.11 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/drupal (Packagist) | 10.3.0 to before 10.3.9 | 10.3.9 | Patch available | GHSA-8mvq-8h2v-j9vf |
| — | drupal/drupal (Packagist) | 11.0.0 to before 11.0.8 | 11.0.8 | Patch available | GHSA-8mvq-8h2v-j9vf |
- Drupal Core VendorDrupal Affected 8.8.0 to before 10.2.11; 10.3.0 to before 10.3.9; 11.0.0 to before 11.0.8 Fixed in 10.2.11, 10.3.9, 11.0.8 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.8.0 to before 10.2.11 Fixed in 10.2.11 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/core (Packagist) Vendor— Affected 10.3.0 to before 10.3.9 Fixed in 10.3.9 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/core (Packagist) Vendor— Affected 11.0.0 to before 11.0.8 Fixed in 11.0.8 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/core-recommended (Packagist) Vendor— Affected 8.8.0 to before 10.2.11 Fixed in 10.2.11 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/core-recommended (Packagist) Vendor— Affected 10.3.0 to before 10.3.9 Fixed in 10.3.9 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/core-recommended (Packagist) Vendor— Affected 11.0.0 to before 11.0.8 Fixed in 11.0.8 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/drupal (Packagist) Vendor— Affected 8.8.0 to before 10.2.11 Fixed in 10.2.11 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/drupal (Packagist) Vendor— Affected 10.3.0 to before 10.3.9 Fixed in 10.3.9 Patch available GHSA-8mvq-8h2v-j9vf
- drupal/drupal (Packagist) Vendor— Affected 11.0.0 to before 11.0.8 Fixed in 11.0.8 Patch available GHSA-8mvq-8h2v-j9vf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.8.0 to before 10.2.11; 10.3.0 to before 10.3.9; 11.0.0 to before 11.0.8 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.8.0 to before 10.2.11; 10.3.0 to before 10.3.9; 11.0.0 to before 11.0.8 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal Core (Drupal) Fixed in 10.2.11, 10.3.9, 11.0.8
- Fix · GHSA-8mvq-8h2v-j9vf drupal/core (Packagist) Fixed in 10.2.11 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/core (Packagist) Fixed in 10.3.9 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/core (Packagist) Fixed in 11.0.8 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/core-recommended (Packagist) Fixed in 10.2.11 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/core-recommended (Packagist) Fixed in 10.3.9 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/core-recommended (Packagist) Fixed in 11.0.8 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/drupal (Packagist) Fixed in 10.2.11 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/drupal (Packagist) Fixed in 10.3.9 Advisory →
- Fix · GHSA-8mvq-8h2v-j9vf drupal/drupal (Packagist) Fixed in 11.0.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Core 10.2.11, 10.3.9, 11.0.8
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2024-36925 Drupal core - Less critical - Gadget chain - SA-CORE-2024-006Priority MEDIUM 51
- TI-2024-36926 Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007Priority MEDIUM 50
- TI-2024-36923 Drupal core - Moderately critical - Access bypass - SA-CORE-2024-004Priority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12393
- 2026-10-03 Alias added: GHSA-8mvq-8h2v-j9vf
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2024-12393 · CVE Program
- CVE-2024-12393 · NVD
- FIRST EPSS
- GHSA-8mvq-8h2v-j9vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences