Gutenberg - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2024-048
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Gutenberg allows Cross Site Request Forgery.This issue affects Gutenberg: from 0.0.0 before 2.13.0, from 3.0.0 before 3.0.5.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00202 10th percentileScored 2026-11-07
Fix Fixed Gutenberg (Drupal): 2.13.0, 3.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Gutenberg | 0.0.0 to before 2.13.0; 3.0.0 to before 3.0.5 | 2.13.0, 3.0.5 | Patch available | CNA |
- Gutenberg VendorDrupal Affected 0.0.0 to before 2.13.0; 3.0.0 to before 3.0.5 Fixed in 2.13.0, 3.0.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupalgutenberg:gutenberg:*:*:*:*:*:drupal:*:* | before 2.13.0; 3.0.0 to before 3.0.5 | Vulnerable | Drupalgutenberg |
- cpe:2.3:a:drupalgutenberg:gutenberg:*:*:*:*:*:drupal:*:* Versions before 2.13.0; 3.0.0 to before 3.0.5 Vulnerable ·Drupalgutenberg
Remediation
- Fix · CNA Gutenberg (Drupal) Fixed in 2.13.0, 3.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13284
- 2026-10-03 Alias added: GHSA-xh2f-mpwc-mhh4
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2024-13284 · CVE Program
- CVE-2024-13284 · NVD
- FIRST EPSS
- GHSA-xh2f-mpwc-mhh4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences