OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) - Critical - Cross Site Scripting - SA-CONTRIB-2024-067
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) allows Cross-Site Scripting (XSS).This issue affects OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client): from 3.0.0 before 3.44.0, from 4.0.0 before 4.0.19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) | 3.0.0 to before 3.44.0; 4.0.0 to before 4.0.19 | 3.44.0, 4.0.19 | Patch available | CNA |
- OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) VendorDrupal Affected 3.0.0 to before 3.44.0; 4.0.0 to before 4.0.19 Fixed in 3.44.0, 4.0.19 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:miniorange:oauth_\&_openid_connect_single_sign-on:*:*:*:*:*:drupal:*:* | 3.0.0 to before 3.44.0; 4.0.0 to before 4.0.19 | Vulnerable | miniOrange |
- cpe:2.3:a:miniorange:oauth_\&_openid_connect_single_sign-on:*:*:*:*:*:drupal:*:* Versions 3.0.0 to before 3.44.0; 4.0.0 to before 4.0.19 Vulnerable ·miniOrange
Remediation
- Fix · CNA OAuth & OpenID Connect Single Sign On – SSO (OAuth/OIDC Client) (Drupal) Fixed in 3.44.0, 4.0.19
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13301
- 2026-10-03 Alias added: GHSA-f6r6-892j-cp9p
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2024-13301 · CVE Program
- CVE-2024-13301 · NVD
- FIRST EPSS
- GHSA-f6r6-892j-cp9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences