Read the docs
TI-2024-15653 Aliases CVE-2024-23634GHSA-75m5-hh4r-q9gx

GeoServer arbitrary file renaming vulnerability in REST Coverage/Data Store API

Priority LOW 28CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. An arbitrary file renaming vulnerability exists in versions prior to 2.23.5 and 2.24.2 that enables an authenticated administrator with permissions to modify stores through the REST Coverage Store or Data Store API to rename arbitrary files and directories with a name that does not end in `.zip`. Store file uploads rename zip files to have a `.zip` extension if it doesn't already have one before unzipping the file. This is fine for file and url upload methods where the files will be in a specific subdirectory of the data directory but, when using the external upload method, this allows arbitrary files and directories to be renamed. Renaming GeoServer files will most likely result in a denial of service, either completely preventing GeoServer from running or effectively deleting specific resources (such as a workspace, layer or style). In some cases, renaming GeoServer files could revert to the default settings for that file which could be relatively harmless like removing contact information or have more serious consequences like allowing users to make OGC requests that the customized settings would have prevented them from making. The impact of renaming non-GeoServer files depends on the specific environment although some sort of denial of service is a likely outcome. Versions 2.23.5 and 2.24.2 contain a fix for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00694 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed geoserver (geoserver): 2.23.5, 2.24.2org.geoserver:gs-restconfig (Maven): 2.23.5, 2.24.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoservergeoserverbefore 2.23.5; 2.24.0 to before 2.24.22.23.5, 2.24.2Patch availableCNA
—org.geoserver:gs-restconfig (Maven)before 2.23.52.23.5Patch availableGHSA-75m5-hh4r-q9gx
—org.geoserver:gs-restconfig (Maven)2.24.0 to before 2.24.22.24.2Patch availableGHSA-75m5-hh4r-q9gx
  • geoserver Vendorgeoserver Affected before 2.23.5; 2.24.0 to before 2.24.2 Fixed in 2.23.5, 2.24.2 Patch available CNA
  • org.geoserver:gs-restconfig (Maven) Vendor— Affected before 2.23.5 Fixed in 2.23.5 Patch available GHSA-75m5-hh4r-q9gx
  • org.geoserver:gs-restconfig (Maven) Vendor— Affected 2.24.0 to before 2.24.2 Fixed in 2.24.2 Patch available GHSA-75m5-hh4r-q9gx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*before 2.23.5; 2.24.0 to before 2.24.2Vulnerablegeoserver
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* Versions before 2.23.5; 2.24.0 to before 2.24.2 Vulnerable ·geoserver

Remediation

  • Fix · CNA geoserver (geoserver) Fixed in 2.23.5, 2.24.2
  • Fix · GHSA-75m5-hh4r-q9gx org.geoserver:gs-restconfig (Maven) Fixed in 2.23.5 Advisory →
  • Fix · GHSA-75m5-hh4r-q9gx org.geoserver:gs-restconfig (Maven) Fixed in 2.24.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-23634
  2. 2026-10-03 Alias added: GHSA-75m5-hh4r-q9gx

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
  • TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
  • TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
See all 16 →

Sources