Read the docs
TI-2024-15659 Aliases CVE-2024-23640GHSA-9rfr-pf2x-g4xf

GeoServer Stored Cross-Site Scripting (XSS) vulnerability in Style Publisher

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.3 and 2.24.0 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources or in a specially crafted datastore file that will execute in the context of another user's browser when viewed in the Style Publisher. Access to the Style Publisher is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.3 and 2.24.0 contain a fix for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00426 37th percentileScored 2026-11-07
Fix Fixed geoserver (geoserver): 2.23.3org.geoserver:gs-main (Maven): 2.23.3+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoservergeoserverbefore 2.23.32.23.3Patch availableCNA
—org.geoserver:gs-main (Maven)before 2.23.32.23.3Patch availableGHSA-9rfr-pf2x-g4xf
—org.geoserver:gs-ows (Maven)before 2.23.32.23.3Patch availableGHSA-9rfr-pf2x-g4xf
  • geoserver Vendorgeoserver Affected before 2.23.3 Fixed in 2.23.3 Patch available CNA
  • org.geoserver:gs-main (Maven) Vendor— Affected before 2.23.3 Fixed in 2.23.3 Patch available GHSA-9rfr-pf2x-g4xf
  • org.geoserver:gs-ows (Maven) Vendor— Affected before 2.23.3 Fixed in 2.23.3 Patch available GHSA-9rfr-pf2x-g4xf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*before 2.23.3Vulnerablegeoserver
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* Versions before 2.23.3 Vulnerable ·geoserver

Remediation

  • Fix · CNA geoserver (geoserver) Fixed in 2.23.3
  • Fix · GHSA-9rfr-pf2x-g4xf org.geoserver:gs-main (Maven) Fixed in 2.23.3 Advisory →
  • Fix · GHSA-9rfr-pf2x-g4xf org.geoserver:gs-ows (Maven) Fixed in 2.23.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-23640
  2. 2026-10-03 Alias added: GHSA-9rfr-pf2x-g4xf

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
  • TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
  • TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
See all 16 →

Sources