Read the docs
TI-2024-15815 Aliases CVE-2024-23821GHSA-88wc-fcj9-q3r9

GeoServer's GWC Demos Page vulnerable to Stored Cross-Site Scripting (XSS)

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the GWC Demos Page. Access to the GWC Demos Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00405 35th percentileScored 2026-11-07
Fix Fixed geoserver (geoserver): 2.23.4org.geoserver:gs-gwc (Maven): 2.24.1, 2.23.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoservergeoserverbefore 2.23.4; = 2.24.02.23.4Patch availableCNA
—org.geoserver:gs-gwc (Maven)2.24.0 to before 2.24.12.24.1Patch availableGHSA-88wc-fcj9-q3r9
—org.geoserver:gs-gwc (Maven)before 2.23.42.23.4Patch availableGHSA-88wc-fcj9-q3r9
  • geoserver Vendorgeoserver Affected before 2.23.4; = 2.24.0 Fixed in 2.23.4 Patch available CNA
  • org.geoserver:gs-gwc (Maven) Vendor— Affected 2.24.0 to before 2.24.1 Fixed in 2.24.1 Patch available GHSA-88wc-fcj9-q3r9
  • org.geoserver:gs-gwc (Maven) Vendor— Affected before 2.23.4 Fixed in 2.23.4 Patch available GHSA-88wc-fcj9-q3r9

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*before 2.23.4Vulnerablegeoserver
cpe:2.3:a:geoserver:geoserver:2.24.0:-:*:*:*:*:*:*2.24.0Vulnerablegeoserver
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* Versions before 2.23.4 Vulnerable ·geoserver
  • cpe:2.3:a:geoserver:geoserver:2.24.0:-:*:*:*:*:*:* Versions 2.24.0 Vulnerable ·geoserver

Remediation

  • Fix · CNA geoserver (geoserver) Fixed in 2.23.4
  • Fix · GHSA-88wc-fcj9-q3r9 org.geoserver:gs-gwc (Maven) Fixed in 2.24.1 Advisory →
  • Fix · GHSA-88wc-fcj9-q3r9 org.geoserver:gs-gwc (Maven) Fixed in 2.23.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-23821
  2. 2026-10-03 Alias added: GHSA-88wc-fcj9-q3r9

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
  • TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
  • TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
See all 16 →

Sources