Read the docs
TI-2024-16231 Aliases CVE-2024-24700GHSA-fgj3-94jj-q56m

WordPress WP Editor plugin <= 1.2.8 - Reflected Cross Site Scripting (XSS) vulnerability

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Benjamin Rojas WP Editor allows Reflected XSS.This issue affects WP Editor: from n/a through 1.2.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00354 29th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
benjaminprojasWP Editorup to 1.2.8—No fix listedCNA
  • WP Editor Vendorbenjaminprojas Affected up to 1.2.8 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-24700
  2. 2026-10-03 Alias added: GHSA-fgj3-94jj-q56m

References

  • TI-2016-08924 The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions. CVSS 3.0CRITICAL 9.8
  • TI-2026-03262 WP Editor <= 1.2.9.2 - Cross-Site Request Forgery to Remote Code Execution via Plugin and Theme File Editor CVSS 3.1HIGH 8.8
  • TI-2016-08923 The wp-editor plugin before 1.2.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
  • TI-2025-02882 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update CVSS 3.1HIGH 7.2
  • TI-2022-02259 WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
  • TI-2024-16819 WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
See all 8 →

Sources