WP Editor <= 1.2.9.2 - Cross-Site Request Forgery to Remote Code Execution via Plugin and Theme File Editor
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The WP Editor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2.9.2. This is due to missing nonce verification in the 'add_plugins_page' and 'add_themes_page' functions. This makes it possible for unauthenticated attackers to overwrite arbitrary plugin and theme PHP files with attacker-controlled code via a forged request, granted they can trick a site administrator into performing an action such as clicking a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| benjaminprojas | WP Editor | up to 1.2.9.2 | — | No fix listed | CNA |
- WP Editor Vendorbenjaminprojas Affected up to 1.2.9.2 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:*:*:* | — | — | benjaminprojas |
- cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:*:*:* Versions — — ·benjaminprojas
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3772
- 2026-10-03 Alias added: GHSA-c7hq-c9cq-6m7w
- 2026-10-25 Priority changed: MEDIUM → LOW
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b1bc4a87-d5de-4d66-9cc5-802ef11f886c?source=cve
- https://plugins.trac.wordpress.org/browser/wp-editor/trunk/classes/WPEditorPlugins.php#L60
- https://plugins.trac.wordpress.org/browser/wp-editor/trunk/classes/WPEditorThemes.php#L103
- https://plugins.trac.wordpress.org/changeset/3480577/
More benjaminprojas vulnerabilities
- TI-2016-08924 The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions. CVSS 3.0CRITICAL 9.8
- TI-2016-08923 The wp-editor plugin before 1.2.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2025-02882 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update CVSS 3.1HIGH 7.2
- TI-2022-02259 WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
- TI-2024-16819 WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
- TI-2021-06443 WP Editor < 1.2.7 - Authenticated SQL injection CVSS 3.1HIGH 7.2
Sources
- CVE-2026-3772 · CVE Program
- CVE-2026-3772 · NVD
- FIRST EPSS
- GHSA-c7hq-c9cq-6m7w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences