Decidim cross-site scripting (XSS) in the admin panel
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Decidim is a participatory democracy framework. The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server. This vulnerability is fixed in 0.27.6 and 0.28.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00341 27th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.27.6, 0.28.1decidim-admin (RubyGems): 0.27.6, 0.28.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| decidim | decidim | before 0.27.6; 0.28.0.rc1 to before 0.28.1 | 0.27.6, 0.28.1 | Patch available | CNA |
| — | decidim-admin (RubyGems) | before 0.27.6 | 0.27.6 | Patch available | GHSA-529p-jj47-w3m3 |
| — | decidim-admin (RubyGems) | 0.28.0.rc1 to before 0.28.1 | 0.28.1 | Patch available | GHSA-529p-jj47-w3m3 |
- decidim Vendordecidim Affected before 0.27.6; 0.28.0.rc1 to before 0.28.1 Fixed in 0.27.6, 0.28.1 Patch available CNA
- decidim-admin (RubyGems) Vendor— Affected before 0.27.6 Fixed in 0.27.6 Patch available GHSA-529p-jj47-w3m3
- decidim-admin (RubyGems) Vendor— Affected 0.28.0.rc1 to before 0.28.1 Fixed in 0.28.1 Patch available GHSA-529p-jj47-w3m3
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:* | before 0.27.6 | Vulnerable | decidim |
| cpe:2.3:a:decidim:decidim:0.28.0:-:*:*:*:ruby:*:* | 0.28.0 | Vulnerable | decidim |
| cpe:2.3:a:decidim:decidim:0.28.0:rc1:*:*:*:ruby:*:* | 0.28.0 rc1 | Vulnerable | decidim |
| cpe:2.3:a:decidim:decidim:0.28.0:rc2:*:*:*:ruby:*:* | 0.28.0 rc2 | Vulnerable | decidim |
| cpe:2.3:a:decidim:decidim:0.28.0:rc3:*:*:*:ruby:*:* | 0.28.0 rc3 | Vulnerable | decidim |
| cpe:2.3:a:decidim:decidim:0.28.0:rc4:*:*:*:ruby:*:* | 0.28.0 rc4 | Vulnerable | decidim |
| cpe:2.3:a:decidim:decidim:0.28.0:rc5:*:*:*:ruby:*:* | 0.28.0 rc5 | Vulnerable | decidim |
- cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:* Versions before 0.27.6 Vulnerable ·decidim
- cpe:2.3:a:decidim:decidim:0.28.0:-:*:*:*:ruby:*:* Versions 0.28.0 Vulnerable ·decidim
- cpe:2.3:a:decidim:decidim:0.28.0:rc1:*:*:*:ruby:*:* Versions 0.28.0 rc1 Vulnerable ·decidim
- cpe:2.3:a:decidim:decidim:0.28.0:rc2:*:*:*:ruby:*:* Versions 0.28.0 rc2 Vulnerable ·decidim
- cpe:2.3:a:decidim:decidim:0.28.0:rc3:*:*:*:ruby:*:* Versions 0.28.0 rc3 Vulnerable ·decidim
- cpe:2.3:a:decidim:decidim:0.28.0:rc4:*:*:*:ruby:*:* Versions 0.28.0 rc4 Vulnerable ·decidim
- cpe:2.3:a:decidim:decidim:0.28.0:rc5:*:*:*:ruby:*:* Versions 0.28.0 rc5 Vulnerable ·decidim
Remediation
- Fix · CNA decidim (decidim) Fixed in 0.27.6, 0.28.1
- Fix · GHSA-529p-jj47-w3m3 decidim-admin (RubyGems) Fixed in 0.27.6 Advisory →
- Fix · GHSA-529p-jj47-w3m3 decidim-admin (RubyGems) Fixed in 0.28.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27095
- 2026-10-03 Alias added: GHSA-529p-jj47-w3m3
References
Advisory 2
More Decidim vulnerabilities
- TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
- TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
- TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
- TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
- TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
- TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
Sources
- CVE-2024-27095 · CVE Program
- CVE-2024-27095 · NVD
- FIRST EPSS
- GHSA-529p-jj47-w3m3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences