LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call. This bypasses the intended behavior of loading configurations only from the hwchase17/langchain-hub GitHub repository. The outcome can be disclosure of an API key for a large language model online service, or remote code execution. (A patch is available as of release 0.1.29 of langchain-core.)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | langchain (PyPI) | before 0.0.339 | 0.0.339 | Patch available | GHSA-h59x-p739-982c |
| — | langchain-core (PyPI) | before 0.1.30 | 0.1.30 | Patch available | GHSA-h59x-p739-982c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- langchain (PyPI) Vendor— Affected before 0.0.339 Fixed in 0.0.339 Patch available GHSA-h59x-p739-982c
- langchain-core (PyPI) Vendor— Affected before 0.1.30 Fixed in 0.1.30 Patch available GHSA-h59x-p739-982c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:* | before 0.1.12 | Vulnerable | langchain-ai |
- cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:* Versions before 0.1.12 Vulnerable ·langchain-ai
Remediation
- Fix · GHSA-h59x-p739-982c langchain (PyPI) Fixed in 0.0.339 Advisory →
- Fix · GHSA-h59x-p739-982c langchain-core (PyPI) Fixed in 0.1.30 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28088
- 2026-10-03 Alias added: GHSA-h59x-p739-982c
References
Exploit 2
Advisory 2
Other 4
- https://github.com/langchain-ai/langchain/commit/e1924b3e93d513ca950c72f8e80e1c133749fba5
- https://github.com/langchain-ai/langchain
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain-core/PYSEC-2024-45.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2024-43.yaml
More langchain-ai Langchain vulnerabilities
- TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
- TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
- TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-28088 · CVE Program
- CVE-2024-28088 · NVD
- FIRST EPSS
- GHSA-h59x-p739-982c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences