GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost
Priority MEDIUM 40CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. It possible to achieve Service Side Request Forgery (SSRF) via the Demo request endpoint if Proxy Base URL has not been set. Upgrading to GeoServer 2.24.4, or 2.25.2, removes the TestWfsPost servlet resolving this issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02321 83rd percentileScored 2026-11-07
Fix Fixed geoserver (geoserver): 2.24.4, 2.25.2org.geoserver:gs-wfs (Maven): 2.24.4, 2.25.2+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | 2.0.0 to before 2.24.4; 2.25.0 to before 2.25.2 | 2.24.4, 2.25.2 | Patch available | CNA |
| — | org.geoserver:gs-wfs (Maven) | 2.0.0 to before 2.24.4 | 2.24.4 | Patch available | GHSA-5gw5-jccf-6hxw |
| — | org.geoserver.web:gs-app (Maven) | 2.0.0 to before 2.24.4 | 2.24.4 | Patch available | GHSA-5gw5-jccf-6hxw |
| — | org.geoserver:gs-wfs (Maven) | 2.25.0 to before 2.25.2 | 2.25.2 | Patch available | GHSA-5gw5-jccf-6hxw |
| — | org.geoserver.web:gs-app (Maven) | 2.25.0 to before 2.25.2 | 2.25.2 | Patch available | GHSA-5gw5-jccf-6hxw |
- geoserver Vendorgeoserver Affected 2.0.0 to before 2.24.4; 2.25.0 to before 2.25.2 Fixed in 2.24.4, 2.25.2 Patch available CNA
- org.geoserver:gs-wfs (Maven) Vendor— Affected 2.0.0 to before 2.24.4 Fixed in 2.24.4 Patch available GHSA-5gw5-jccf-6hxw
- org.geoserver.web:gs-app (Maven) Vendor— Affected 2.0.0 to before 2.24.4 Fixed in 2.24.4 Patch available GHSA-5gw5-jccf-6hxw
- org.geoserver:gs-wfs (Maven) Vendor— Affected 2.25.0 to before 2.25.2 Fixed in 2.25.2 Patch available GHSA-5gw5-jccf-6hxw
- org.geoserver.web:gs-app (Maven) Vendor— Affected 2.25.0 to before 2.25.2 Fixed in 2.25.2 Patch available GHSA-5gw5-jccf-6hxw
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.24.4, 2.25.2
- Fix · GHSA-5gw5-jccf-6hxw org.geoserver:gs-wfs (Maven) Fixed in 2.24.4 Advisory →
- Fix · GHSA-5gw5-jccf-6hxw org.geoserver.web:gs-app (Maven) Fixed in 2.24.4 Advisory →
- Fix · GHSA-5gw5-jccf-6hxw org.geoserver:gs-wfs (Maven) Fixed in 2.25.2 Advisory →
- Fix · GHSA-5gw5-jccf-6hxw org.geoserver.web:gs-app (Maven) Fixed in 2.25.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29198
- 2026-10-03 Alias added: GHSA-5gw5-jccf-6hxw
References
Advisory 3
More geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
- TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-29198 · CVE Program
- CVE-2024-29198 · NVD
- FIRST EPSS
- GHSA-5gw5-jccf-6hxw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences