Read the docs
TI-2024-19372 Aliases CVE-2024-29203GHSA-438c-3975-5x3f

TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content insertion code. This allowed `iframe` elements containing malicious code to execute when inserted into the editor. These `iframe` elements are restricted in their permissions by same-origin browser protections, but could still trigger operations such as downloading of malicious assets. This vulnerability is fixed in 6.8.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00713 53rd percentileScored 2026-11-07
Fix Fixed tinymce (tinymce): 6.8.1tinymce (npm): 6.8.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
tinymcetinymcebefore 6.8.16.8.1Patch availableCNA
—tinymce (npm)before 6.8.16.8.1Patch availableGHSA-438c-3975-5x3f
—TinyMCE (NuGet)before 6.8.16.8.1Patch availableGHSA-438c-3975-5x3f
—tinymce/tinymce (Packagist)before 6.8.16.8.1Patch availableGHSA-438c-3975-5x3f
  • tinymce Vendortinymce Affected before 6.8.1 Fixed in 6.8.1 Patch available CNA
  • tinymce (npm) Vendor— Affected before 6.8.1 Fixed in 6.8.1 Patch available GHSA-438c-3975-5x3f
  • TinyMCE (NuGet) Vendor— Affected before 6.8.1 Fixed in 6.8.1 Patch available GHSA-438c-3975-5x3f
  • tinymce/tinymce (Packagist) Vendor— Affected before 6.8.1 Fixed in 6.8.1 Patch available GHSA-438c-3975-5x3f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*before 6.8.1; 6.8.2 to before 7.0.0VulnerableTiny
  • cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:* Versions before 6.8.1; 6.8.2 to before 7.0.0 Vulnerable ·Tiny

Remediation

  • Fix · CNA tinymce (tinymce) Fixed in 6.8.1
  • Fix · GHSA-438c-3975-5x3f tinymce (npm) Fixed in 6.8.1 Advisory →
  • Fix · GHSA-438c-3975-5x3f TinyMCE (NuGet) Fixed in 6.8.1 Advisory →
  • Fix · GHSA-438c-3975-5x3f tinymce/tinymce (Packagist) Fixed in 6.8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-29203
  2. 2026-10-03 Alias added: GHSA-438c-3975-5x3f

References

  • TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
  • TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
  • TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
  • TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
  • TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
  • TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
See all 20 →

Sources