Read the docs
TI-2024-23008 Aliases CVE-2024-34711GHSA-mc43-4fqr-c965

GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)

Priority MEDIUM 46CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

GeoServer is an open source server that allows users to share and edit geospatial data. An improper URI validation vulnerability exists that enables an unauthorized attacker to perform XML External Entities (XEE) attack, then send GET request to any HTTP server. By default, GeoServer use PreventLocalEntityResolver class from GeoTools to filter out malicious URIs in XML entities before resolving them. The URI must match the regex (?i)(jar:file|http|vfs)[^?#;]*\\.xsd. But the regex leaves a chance for attackers to request to any HTTP server or limited file. Attacker can abuse this to scan internal networks and gain information about them then exploit further. GeoServer 2.25.0 and greater default to the use of ENTITY_RESOLUTION_ALLOWLIST and does not require you to provide a system property.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00311 24th percentileScored 2026-11-07
Fix Fixed geoserver (geoserver): 2.25.0org.geoserver.web:gs-web-app (Maven): 2.25.0+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoservergeoserverbefore 2.25.02.25.0Patch availableCNA
—org.geoserver.web:gs-web-app (Maven)before 2.25.02.25.0Patch availableGHSA-mc43-4fqr-c965
—org.geoserver.main:gs-main (Maven)before 2.25.02.25.0Patch availableGHSA-mc43-4fqr-c965
  • geoserver Vendorgeoserver Affected before 2.25.0 Fixed in 2.25.0 Patch available CNA
  • org.geoserver.web:gs-web-app (Maven) Vendor— Affected before 2.25.0 Fixed in 2.25.0 Patch available GHSA-mc43-4fqr-c965
  • org.geoserver.main:gs-main (Maven) Vendor— Affected before 2.25.0 Fixed in 2.25.0 Patch available GHSA-mc43-4fqr-c965

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:*before 2.25.0VulnerableOSGeo
  • cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:* Versions before 2.25.0 Vulnerable ·OSGeo

Remediation

  • Fix · CNA geoserver (geoserver) Fixed in 2.25.0
  • Fix · GHSA-mc43-4fqr-c965 org.geoserver.web:gs-web-app (Maven) Fixed in 2.25.0 Advisory →
  • Fix · GHSA-mc43-4fqr-c965 org.geoserver.main:gs-main (Maven) Fixed in 2.25.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-34711
  2. 2026-10-03 Alias added: GHSA-mc43-4fqr-c965

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
  • TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
See all 33 →

Sources