Read the docs
TI-2024-25614 Aliases CVE-2024-38356GHSA-9hcv-j9pv-qmph

TinyMCE Cross-Site Scripting (XSS) vulnerability using noneditable_regexp option

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content extraction code. When using the `noneditable_regexp` option, specially crafted HTML attributes containing malicious code were able to be executed when content was extracted from the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that, when using the `noneditable_regexp` option, any content within an attribute is properly verified to match the configured regular expression before being added. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00529 45th percentileScored 2026-11-07
Fix Fixed tinymce (tinymce): 5.11.0, 6.8.4, 7.2.0tinymce (npm): 5.11.0, 6.8.4, 7.2.0+3 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
tinymcetinymcebefore 5.11.0; 6.0.0 to before 6.8.4; 7.0.0 to before 7.2.05.11.0, 6.8.4, 7.2.0Patch availableCNA
—tinymce (npm)before 5.11.05.11.0Patch availableGHSA-9hcv-j9pv-qmph
—TinyMCE (NuGet)before 5.11.05.11.0Patch availableGHSA-9hcv-j9pv-qmph
—tinymce/tinymce (Packagist)before 5.11.05.11.0Patch availableGHSA-9hcv-j9pv-qmph
—tinymce (npm)6.0.0 to before 6.8.46.8.4Patch availableGHSA-9hcv-j9pv-qmph
—tinymce (npm)7.0.0 to before 7.2.07.2.0Patch availableGHSA-9hcv-j9pv-qmph
—TinyMCE (NuGet)6.0.0 to before 6.8.46.8.4Patch availableGHSA-9hcv-j9pv-qmph
—TinyMCE (NuGet)7.0.0 to before 7.2.07.2.0Patch availableGHSA-9hcv-j9pv-qmph
—tinymce/tinymce (Packagist)6.0.0 to before 6.8.46.8.4Patch availableGHSA-9hcv-j9pv-qmph
—tinymce/tinymce (Packagist)7.0.0 to before 7.2.07.2.0Patch availableGHSA-9hcv-j9pv-qmph
—django-tinymce (PyPI)before 4.1.04.1.0Patch availableGHSA-9hcv-j9pv-qmph
  • tinymce Vendortinymce Affected before 5.11.0; 6.0.0 to before 6.8.4; 7.0.0 to before 7.2.0 Fixed in 5.11.0, 6.8.4, 7.2.0 Patch available CNA
  • tinymce (npm) Vendor— Affected before 5.11.0 Fixed in 5.11.0 Patch available GHSA-9hcv-j9pv-qmph
  • TinyMCE (NuGet) Vendor— Affected before 5.11.0 Fixed in 5.11.0 Patch available GHSA-9hcv-j9pv-qmph
  • tinymce/tinymce (Packagist) Vendor— Affected before 5.11.0 Fixed in 5.11.0 Patch available GHSA-9hcv-j9pv-qmph
  • tinymce (npm) Vendor— Affected 6.0.0 to before 6.8.4 Fixed in 6.8.4 Patch available GHSA-9hcv-j9pv-qmph
  • tinymce (npm) Vendor— Affected 7.0.0 to before 7.2.0 Fixed in 7.2.0 Patch available GHSA-9hcv-j9pv-qmph
  • TinyMCE (NuGet) Vendor— Affected 6.0.0 to before 6.8.4 Fixed in 6.8.4 Patch available GHSA-9hcv-j9pv-qmph
  • TinyMCE (NuGet) Vendor— Affected 7.0.0 to before 7.2.0 Fixed in 7.2.0 Patch available GHSA-9hcv-j9pv-qmph
  • tinymce/tinymce (Packagist) Vendor— Affected 6.0.0 to before 6.8.4 Fixed in 6.8.4 Patch available GHSA-9hcv-j9pv-qmph
  • tinymce/tinymce (Packagist) Vendor— Affected 7.0.0 to before 7.2.0 Fixed in 7.2.0 Patch available GHSA-9hcv-j9pv-qmph
  • django-tinymce (PyPI) Vendor— Affected before 4.1.0 Fixed in 4.1.0 Patch available GHSA-9hcv-j9pv-qmph

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*——Tiny
  • cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:* Versions — — ·Tiny

Remediation

  • Fix · CNA tinymce (tinymce) Fixed in 5.11.0, 6.8.4, 7.2.0
  • Fix · GHSA-9hcv-j9pv-qmph tinymce (npm) Fixed in 5.11.0 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph TinyMCE (NuGet) Fixed in 5.11.0 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph tinymce/tinymce (Packagist) Fixed in 5.11.0 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph tinymce (npm) Fixed in 6.8.4 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph tinymce (npm) Fixed in 7.2.0 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph TinyMCE (NuGet) Fixed in 6.8.4 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph TinyMCE (NuGet) Fixed in 7.2.0 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph tinymce/tinymce (Packagist) Fixed in 6.8.4 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph tinymce/tinymce (Packagist) Fixed in 7.2.0 Advisory →
  • Fix · GHSA-9hcv-j9pv-qmph django-tinymce (PyPI) Fixed in 4.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-38356
  2. 2026-10-03 Alias added: GHSA-9hcv-j9pv-qmph

References

  • TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
  • TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
  • TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
  • TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
  • TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
  • TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
See all 20 →

Sources