TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tinymce | tinymce | before 5.11.0; 6.0.0 to before 6.8.4; 7.0.0 to before 7.2.0 | 5.11.0, 6.8.4, 7.2.0 | Patch available | CNA |
| — | tinymce (npm) | before 5.11.0 | 5.11.0 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | TinyMCE (NuGet) | before 5.11.0 | 5.11.0 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | tinymce/tinymce (Packagist) | before 5.11.0 | 5.11.0 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | tinymce (npm) | 6.0.0 to before 6.8.4 | 6.8.4 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | tinymce (npm) | 7.0.0 to before 7.2.0 | 7.2.0 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | TinyMCE (NuGet) | 6.0.0 to before 6.8.4 | 6.8.4 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | TinyMCE (NuGet) | 7.0.0 to before 7.2.0 | 7.2.0 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | tinymce/tinymce (Packagist) | 6.0.0 to before 6.8.4 | 6.8.4 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | tinymce/tinymce (Packagist) | 7.0.0 to before 7.2.0 | 7.2.0 | Patch available | GHSA-w9jx-4g6g-rp7x |
| — | django-tinymce (PyPI) | before 4.1.0 | 4.1.0 | Patch available | GHSA-w9jx-4g6g-rp7x |
- tinymce Vendortinymce Affected before 5.11.0; 6.0.0 to before 6.8.4; 7.0.0 to before 7.2.0 Fixed in 5.11.0, 6.8.4, 7.2.0 Patch available CNA
- tinymce (npm) Vendor— Affected before 5.11.0 Fixed in 5.11.0 Patch available GHSA-w9jx-4g6g-rp7x
- TinyMCE (NuGet) Vendor— Affected before 5.11.0 Fixed in 5.11.0 Patch available GHSA-w9jx-4g6g-rp7x
- tinymce/tinymce (Packagist) Vendor— Affected before 5.11.0 Fixed in 5.11.0 Patch available GHSA-w9jx-4g6g-rp7x
- tinymce (npm) Vendor— Affected 6.0.0 to before 6.8.4 Fixed in 6.8.4 Patch available GHSA-w9jx-4g6g-rp7x
- tinymce (npm) Vendor— Affected 7.0.0 to before 7.2.0 Fixed in 7.2.0 Patch available GHSA-w9jx-4g6g-rp7x
- TinyMCE (NuGet) Vendor— Affected 6.0.0 to before 6.8.4 Fixed in 6.8.4 Patch available GHSA-w9jx-4g6g-rp7x
- TinyMCE (NuGet) Vendor— Affected 7.0.0 to before 7.2.0 Fixed in 7.2.0 Patch available GHSA-w9jx-4g6g-rp7x
- tinymce/tinymce (Packagist) Vendor— Affected 6.0.0 to before 6.8.4 Fixed in 6.8.4 Patch available GHSA-w9jx-4g6g-rp7x
- tinymce/tinymce (Packagist) Vendor— Affected 7.0.0 to before 7.2.0 Fixed in 7.2.0 Patch available GHSA-w9jx-4g6g-rp7x
- django-tinymce (PyPI) Vendor— Affected before 4.1.0 Fixed in 4.1.0 Patch available GHSA-w9jx-4g6g-rp7x
Remediation
- Fix · CNA tinymce (tinymce) Fixed in 5.11.0, 6.8.4, 7.2.0
- Fix · GHSA-w9jx-4g6g-rp7x tinymce (npm) Fixed in 5.11.0 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x TinyMCE (NuGet) Fixed in 5.11.0 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x tinymce/tinymce (Packagist) Fixed in 5.11.0 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x tinymce (npm) Fixed in 6.8.4 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x tinymce (npm) Fixed in 7.2.0 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x TinyMCE (NuGet) Fixed in 6.8.4 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x TinyMCE (NuGet) Fixed in 7.2.0 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x tinymce/tinymce (Packagist) Fixed in 6.8.4 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x tinymce/tinymce (Packagist) Fixed in 7.2.0 Advisory →
- Fix · GHSA-w9jx-4g6g-rp7x django-tinymce (PyPI) Fixed in 4.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38357
- 2026-10-03 Alias added: GHSA-w9jx-4g6g-rp7x
References
Other 7
- https://github.com/tinymce/tinymce/security/advisories/GHSA-w9jx-4g6g-rp7x
- https://github.com/tinymce/tinymce/commit/5acb741665a98e83d62b91713c800abbff43b00d
- https://owasp.org/www-community/attacks/xss
- https://www.tiny.cloud/docs/tinymce/6/6.8.4-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/7/7.2-release-notes/#overview
- https://github.com/tinymce/tinymce/commit/a9fb858509f86dacfa8b01cfd34653b408983ac0
- https://github.com/tinymce/tinymce
More tinymce vulnerabilities
- TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
- TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
- TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
- TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
- TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
- TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
Sources
- CVE-2024-38357 · CVE Program
- CVE-2024-38357 · NVD
- FIRST EPSS
- GHSA-w9jx-4g6g-rp7x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences