Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds
Priority LOW 35CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Decidim is a participatory democracy framework. The meeting embeds feature used in the online or hybrid meetings is subject to potential XSS attack through a malformed URL. This vulnerability is fixed in 0.28.3 and 0.29.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00264 18th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.28.3decidim-meetings (RubyGems): 0.28.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| decidim | decidim | 0.28.0 to before 0.28.3 | 0.28.3 | Patch available | CNA |
| — | decidim-meetings (RubyGems) | 0.28.0 to before 0.28.3 | 0.28.3 | Patch available | GHSA-j4h6-gcj7-7v9v |
- decidim Vendordecidim Affected 0.28.0 to before 0.28.3 Fixed in 0.28.3 Patch available CNA
- decidim-meetings (RubyGems) Vendor— Affected 0.28.0 to before 0.28.3 Fixed in 0.28.3 Patch available GHSA-j4h6-gcj7-7v9v
Remediation
- Fix · CNA decidim (decidim) Fixed in 0.28.3
- Fix · GHSA-j4h6-gcj7-7v9v decidim-meetings (RubyGems) Fixed in 0.28.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45594
- 2026-10-03 Alias added: GHSA-j4h6-gcj7-7v9v
References
More Decidim vulnerabilities
- TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
- TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
- TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
- TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
- TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
- TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
Sources
- CVE-2024-45594 · CVE Program
- CVE-2024-45594 · NVD
- FIRST EPSS
- GHSA-j4h6-gcj7-7v9v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences