Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-915 and CWE-502.
Summary
Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 7.0 before 7.102, from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9. Drupal core contains a chain of methods that is exploitable when an insecure deserialization vulnerability exists on the site. This so-called gadget chain presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 7.0 to before 7.102; 8.0.0 to before 10.2.11; 10.3.0 to before 10.3.9 | 7.102, 10.2.11, 10.3.9 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.8.0 to before 10.2.11 | 10.2.11 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/core (Packagist) | 10.3.0 to before 10.3.9 | 10.3.9 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/core (Packagist) | 7.0 to before 7.102 | 7.102 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/core-recommended (Packagist) | 8.8.0 to before 10.2.11 | 10.2.11 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/core-recommended (Packagist) | 10.3.0 to before 10.3.9 | 10.3.9 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/core-recommended (Packagist) | 7.0 to before 7.102 | 7.102 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/drupal (Packagist) | 8.8.0 to before 10.2.11 | 10.2.11 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/drupal (Packagist) | 10.3.0 to before 10.3.9 | 10.3.9 | Patch available | GHSA-gvf2-2f4g-jqf4 |
| — | drupal/drupal (Packagist) | 7.0 to before 7.102 | 7.102 | Patch available | GHSA-gvf2-2f4g-jqf4 |
- Drupal Core VendorDrupal Affected 7.0 to before 7.102; 8.0.0 to before 10.2.11; 10.3.0 to before 10.3.9 Fixed in 7.102, 10.2.11, 10.3.9 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.8.0 to before 10.2.11 Fixed in 10.2.11 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/core (Packagist) Vendor— Affected 10.3.0 to before 10.3.9 Fixed in 10.3.9 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/core (Packagist) Vendor— Affected 7.0 to before 7.102 Fixed in 7.102 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/core-recommended (Packagist) Vendor— Affected 8.8.0 to before 10.2.11 Fixed in 10.2.11 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/core-recommended (Packagist) Vendor— Affected 10.3.0 to before 10.3.9 Fixed in 10.3.9 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/core-recommended (Packagist) Vendor— Affected 7.0 to before 7.102 Fixed in 7.102 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/drupal (Packagist) Vendor— Affected 8.8.0 to before 10.2.11 Fixed in 10.2.11 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/drupal (Packagist) Vendor— Affected 10.3.0 to before 10.3.9 Fixed in 10.3.9 Patch available GHSA-gvf2-2f4g-jqf4
- drupal/drupal (Packagist) Vendor— Affected 7.0 to before 7.102 Fixed in 7.102 Patch available GHSA-gvf2-2f4g-jqf4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0 to before 7.102; 8.0.0 to before 10.2.11; 10.3.0 to before 10.3.9 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.102; 8.0.0 to before 10.2.11; 10.3.0 to before 10.3.9 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal Core (Drupal) Fixed in 7.102, 10.2.11, 10.3.9
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/core (Packagist) Fixed in 10.2.11 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/core (Packagist) Fixed in 10.3.9 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/core (Packagist) Fixed in 7.102 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/core-recommended (Packagist) Fixed in 10.2.11 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/core-recommended (Packagist) Fixed in 10.3.9 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/core-recommended (Packagist) Fixed in 7.102 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/drupal (Packagist) Fixed in 10.2.11 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/drupal (Packagist) Fixed in 10.3.9 Advisory →
- Fix · GHSA-gvf2-2f4g-jqf4 drupal/drupal (Packagist) Fixed in 7.102 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-55638
- 2026-10-03 Alias added: GHSA-gvf2-2f4g-jqf4
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2024-55638 · CVE Program
- CVE-2024-55638 · NVD
- FIRST EPSS
- GHSA-gvf2-2f4g-jqf4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences