Read the docs
TI-2025-15581 Aliases CVE-2025-21621GHSA-w66h-j855-qr72

GeoServer Reflected Cross-Site Scripting (XSS) vulnerability in WMS GetFeatureInfo HTML format

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.25.0, a reflected cross-site scripting (XSS) vulnerability exists in the WMS GetFeatureInfo HTML output format that enables a remote attacker to execute arbitrary JavaScript code in a victim's browser through specially crafted SLD_BODY parameters. This issue has been patched in version 2.25.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00317 24th percentileScored 2026-11-07
Fix Fixed geoserver (geoserver): 2.25.0org.geoserver.web:gs-web-app (Maven): 2.25.0+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoservergeoserverbefore 2.25.02.25.0Patch availableCNA
—org.geoserver.web:gs-web-app (Maven)before 2.25.02.25.0Patch availableGHSA-w66h-j855-qr72
—org.geoserver:gs-wms (Maven)before 2.25.02.25.0Patch availableGHSA-w66h-j855-qr72
  • geoserver Vendorgeoserver Affected before 2.25.0 Fixed in 2.25.0 Patch available CNA
  • org.geoserver.web:gs-web-app (Maven) Vendor— Affected before 2.25.0 Fixed in 2.25.0 Patch available GHSA-w66h-j855-qr72
  • org.geoserver:gs-wms (Maven) Vendor— Affected before 2.25.0 Fixed in 2.25.0 Patch available GHSA-w66h-j855-qr72

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*before 2.25.0Vulnerablegeoserver
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* Versions before 2.25.0 Vulnerable ·geoserver

Remediation

  • Fix · CNA geoserver (geoserver) Fixed in 2.25.0
  • Fix · GHSA-w66h-j855-qr72 org.geoserver.web:gs-web-app (Maven) Fixed in 2.25.0 Advisory →
  • Fix · GHSA-w66h-j855-qr72 org.geoserver:gs-wms (Maven) Fixed in 2.25.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-21621
  2. 2026-10-03 Alias added: GHSA-w66h-j855-qr72

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2023-28098 GeoServer arbitrary file upload vulnerability in REST Coverage Store API CVSS 3.1HIGH 7.2
  • TI-2024-15662 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form CVSS 3.1MEDIUM 4.8
  • TI-2023-28099 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in REST Resources API CVSS 3.1MEDIUM 4.8
See all 16 →

Sources