GeoServer Missing Authorization on REST API Index
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
GeoServer is an open source server that allows users to share and edit geospatial data. It is possible to bypass the default REST API security and access the index page. The REST API security handles rest and its subpaths but not rest with an extension (e.g., rest.html). The REST API index can disclose whether certain extensions are installed. This vulnerability is fixed in 2.26.3 and 2.25.6. As a workaround, in ${GEOSERVER_DATA_DIR}/security/config.xml, change the paths for the rest filter to /rest.*,/rest/** and change the paths for the gwc filter to /gwc/rest.*,/gwc/rest/** and restart GeoServer.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | 2.26.0 to before 2.26.3; before 2.25.6 | 2.26.3, 2.25.6 | Patch available | CNA |
| — | org.geoserver.web:gs-web-app (Maven) | 2.26.0 to before 2.26.3 | 2.26.3 | Patch available | GHSA-h86g-x8mm-78m5 |
| — | org.geoserver.web:gs-web-app (Maven) | before 2.25.6 | 2.25.6 | Patch available | GHSA-h86g-x8mm-78m5 |
| — | org.geoserver:gs-rest (Maven) | 2.26.0 to before 2.26.3 | 2.26.3 | Patch available | GHSA-h86g-x8mm-78m5 |
| — | org.geoserver:gs-rest (Maven) | before 2.25.6 | 2.25.6 | Patch available | GHSA-h86g-x8mm-78m5 |
- geoserver Vendorgeoserver Affected 2.26.0 to before 2.26.3; before 2.25.6 Fixed in 2.26.3, 2.25.6 Patch available CNA
- org.geoserver.web:gs-web-app (Maven) Vendor— Affected 2.26.0 to before 2.26.3 Fixed in 2.26.3 Patch available GHSA-h86g-x8mm-78m5
- org.geoserver.web:gs-web-app (Maven) Vendor— Affected before 2.25.6 Fixed in 2.25.6 Patch available GHSA-h86g-x8mm-78m5
- org.geoserver:gs-rest (Maven) Vendor— Affected 2.26.0 to before 2.26.3 Fixed in 2.26.3 Patch available GHSA-h86g-x8mm-78m5
- org.geoserver:gs-rest (Maven) Vendor— Affected before 2.25.6 Fixed in 2.25.6 Patch available GHSA-h86g-x8mm-78m5
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.26.3, 2.25.6
- Fix · GHSA-h86g-x8mm-78m5 org.geoserver.web:gs-web-app (Maven) Fixed in 2.26.3 Advisory →
- Fix · GHSA-h86g-x8mm-78m5 org.geoserver.web:gs-web-app (Maven) Fixed in 2.25.6 Advisory →
- Fix · GHSA-h86g-x8mm-78m5 org.geoserver:gs-rest (Maven) Fixed in 2.26.3 Advisory →
- Fix · GHSA-h86g-x8mm-78m5 org.geoserver:gs-rest (Maven) Fixed in 2.25.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27505
- 2026-10-03 Alias added: GHSA-h86g-x8mm-78m5
References
Patch 2
Advisory 2
More geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
- TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-27505 · CVE Program
- CVE-2025-27505 · NVD
- FIRST EPSS
- GHSA-h86g-x8mm-78m5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences