Read the docs
TI-2025-20343 Aliases CVE-2025-27511GHSA-g628-r368-6vh7

GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection

Priority LOW 36CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.27.0 of the GeoServer DB2 DataStore Extension, an administrator can perform a JNDI attack through specially crafted DB2 jdbc url leading to to Remote Code Execution (RCE). Version 2.27.0 fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01074 65th percentileScored 2026-11-07
Fix Fixed org.geoserver.extension:gs-db2 (geoserver): 2.27.0org.geoserver.extension:gs-db2 (Maven): 2.27.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoserverorg.geoserver.extension:gs-db2before 2.27.02.27.0Patch availableCNA
—org.geoserver.extension:gs-db2 (Maven)before 2.27.02.27.0Patch availableGHSA-g628-r368-6vh7
  • org.geoserver.extension:gs-db2 Vendorgeoserver Affected before 2.27.0 Fixed in 2.27.0 Patch available CNA
  • org.geoserver.extension:gs-db2 (Maven) Vendor— Affected before 2.27.0 Fixed in 2.27.0 Patch available GHSA-g628-r368-6vh7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:*before 2.27.0VulnerableOSGeo
  • cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:* Versions before 2.27.0 Vulnerable ·OSGeo

Remediation

  • Fix · CNA org.geoserver.extension:gs-db2 (geoserver) Fixed in 2.27.0
  • Fix · GHSA-g628-r368-6vh7 org.geoserver.extension:gs-db2 (Maven) Fixed in 2.27.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-27511
  2. 2026-10-03 Alias added: GHSA-g628-r368-6vh7

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
  • TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
See all 33 →

Sources