Read the docs
TI-2025-21485 Aliases CVE-2025-30145GHSA-gr67-pwcv-76gf

GeoServer has an Infinite Loop Vulnerability in Jiffle process

Priority MEDIUM 40CWE-835Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-835.

Summary

GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00534 45th percentileScored 2026-11-07
Fix Fixed geoserver (geoserver): 2.26.3, 2.25.7org.geoserver.web:gs-web-app (Maven): 2.26.3, 2.25.7+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
geoservergeoserver2.26.0 to before 2.26.3; before 2.25.72.26.3, 2.25.7Patch availableCNA
—org.geoserver.web:gs-web-app (Maven)2.26.0 to before 2.26.32.26.3Patch availableGHSA-gr67-pwcv-76gf
—org.geoserver:gs-wms (Maven)2.26.0 to before 2.26.32.26.3Patch availableGHSA-gr67-pwcv-76gf
—org.geoserver.extension:gs-wps-core (Maven)2.26.0 to before 2.26.32.26.3Patch availableGHSA-gr67-pwcv-76gf
—org.geoserver.web:gs-web-app (Maven)before 2.25.72.25.7Patch availableGHSA-gr67-pwcv-76gf
—org.geoserver:gs-wms (Maven)before 2.25.72.25.7Patch availableGHSA-gr67-pwcv-76gf
—org.geoserver.extension:gs-wps-core (Maven)before 2.25.72.25.7Patch availableGHSA-gr67-pwcv-76gf
  • geoserver Vendorgeoserver Affected 2.26.0 to before 2.26.3; before 2.25.7 Fixed in 2.26.3, 2.25.7 Patch available CNA
  • org.geoserver.web:gs-web-app (Maven) Vendor— Affected 2.26.0 to before 2.26.3 Fixed in 2.26.3 Patch available GHSA-gr67-pwcv-76gf
  • org.geoserver:gs-wms (Maven) Vendor— Affected 2.26.0 to before 2.26.3 Fixed in 2.26.3 Patch available GHSA-gr67-pwcv-76gf
  • org.geoserver.extension:gs-wps-core (Maven) Vendor— Affected 2.26.0 to before 2.26.3 Fixed in 2.26.3 Patch available GHSA-gr67-pwcv-76gf
  • org.geoserver.web:gs-web-app (Maven) Vendor— Affected before 2.25.7 Fixed in 2.25.7 Patch available GHSA-gr67-pwcv-76gf
  • org.geoserver:gs-wms (Maven) Vendor— Affected before 2.25.7 Fixed in 2.25.7 Patch available GHSA-gr67-pwcv-76gf
  • org.geoserver.extension:gs-wps-core (Maven) Vendor— Affected before 2.25.7 Fixed in 2.25.7 Patch available GHSA-gr67-pwcv-76gf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:*before 2.25.7; 2.26.0 to before 2.26.3VulnerableOSGeo
  • cpe:2.3:a:osgeo:geoserver:*:*:*:*:*:*:*:* Versions before 2.25.7; 2.26.0 to before 2.26.3 Vulnerable ·OSGeo

Remediation

  • Fix · CNA geoserver (geoserver) Fixed in 2.26.3, 2.25.7
  • Fix · GHSA-gr67-pwcv-76gf org.geoserver.web:gs-web-app (Maven) Fixed in 2.26.3 Advisory →
  • Fix · GHSA-gr67-pwcv-76gf org.geoserver:gs-wms (Maven) Fixed in 2.26.3 Advisory →
  • Fix · GHSA-gr67-pwcv-76gf org.geoserver.extension:gs-wps-core (Maven) Fixed in 2.26.3 Advisory →
  • Fix · GHSA-gr67-pwcv-76gf org.geoserver.web:gs-web-app (Maven) Fixed in 2.25.7 Advisory →
  • Fix · GHSA-gr67-pwcv-76gf org.geoserver:gs-wms (Maven) Fixed in 2.25.7 Advisory →
  • Fix · GHSA-gr67-pwcv-76gf org.geoserver.extension:gs-wps-core (Maven) Fixed in 2.25.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-30145
  2. 2026-10-03 Alias added: GHSA-gr67-pwcv-76gf
  3. 2026-11-07 Priority changed: LOW → MEDIUM

References

  • TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
  • TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
  • TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
  • TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
See all 33 →

Sources