Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2025-004
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5. It also affects the Drupal 7 module from versions 7.x-1.0 through 7.x-1.12.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal core | 8.0.0 to before 10.3.14; 10.4.0 to before 10.4.5; 11.0.0 to before 11.0.13; 11.1.0 to before 11.1.5 | 10.3.14, 10.4.5, 11.0.13, 11.1.5 | Patch available | CNA |
| Drupal | Link | 7.x-1.0 – 7.x-1.12 | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 8.0.0 to before 10.3.14 | 10.3.14 | Patch available | GHSA-m4wj-hhwj-47qp |
| — | drupal/core (Packagist) | 10.4.0 to before 10.4.5 | 10.4.5 | Patch available | GHSA-m4wj-hhwj-47qp |
| — | drupal/core (Packagist) | 11.0.0 to before 11.0.13 | 11.0.13 | Patch available | GHSA-m4wj-hhwj-47qp |
| — | drupal/core (Packagist) | 11.1.0 to before 11.1.5 | 11.1.5 | Patch available | GHSA-m4wj-hhwj-47qp |
- Drupal core VendorDrupal Affected 8.0.0 to before 10.3.14; 10.4.0 to before 10.4.5; 11.0.0 to before 11.0.13; 11.1.0 to before 11.1.5 Fixed in 10.3.14, 10.4.5, 11.0.13, 11.1.5 Patch available CNA
- Link VendorDrupal Affected 7.x-1.0 – 7.x-1.12 Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 10.3.14 Fixed in 10.3.14 Patch available GHSA-m4wj-hhwj-47qp
- drupal/core (Packagist) Vendor— Affected 10.4.0 to before 10.4.5 Fixed in 10.4.5 Patch available GHSA-m4wj-hhwj-47qp
- drupal/core (Packagist) Vendor— Affected 11.0.0 to before 11.0.13 Fixed in 11.0.13 Patch available GHSA-m4wj-hhwj-47qp
- drupal/core (Packagist) Vendor— Affected 11.1.0 to before 11.1.5 Fixed in 11.1.5 Patch available GHSA-m4wj-hhwj-47qp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.0.0 to before 10.3.14; 10.4.0 to before 10.4.5; 11.0.0 to before 11.0.13; 11.1.0 to before 11.1.5 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 10.3.14; 10.4.0 to before 10.4.5; 11.0.0 to before 11.0.13; 11.1.0 to before 11.1.5 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal core (Drupal) Fixed in 10.3.14, 10.4.5, 11.0.13, 11.1.5
- Fix · GHSA-m4wj-hhwj-47qp drupal/core (Packagist) Fixed in 10.3.14 Advisory →
- Fix · GHSA-m4wj-hhwj-47qp drupal/core (Packagist) Fixed in 10.4.5 Advisory →
- Fix · GHSA-m4wj-hhwj-47qp drupal/core (Packagist) Fixed in 11.0.13 Advisory →
- Fix · GHSA-m4wj-hhwj-47qp drupal/core (Packagist) Fixed in 11.1.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31675
- 2026-10-03 Alias added: GHSA-m4wj-hhwj-47qp
References
Advisory 4
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2025-31675 · CVE Program
- CVE-2025-31675 · NVD
- FIRST EPSS
- GHSA-m4wj-hhwj-47qp · GitHub Advisory Database · CC BY 4.0
- CVE-2025-31675 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences