Hax CMS Stored Cross-Site Scripting vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, the application does not sufficiently sanitize user input, allowing for the execution of arbitrary JavaScript code. The 'saveNode' and 'saveManifest' endpoints take user input and store it in the JSON schema for the site. This content is then rendered in the generated HAX site. Although the application does not allow users to supply a `script` tag, it does allow the use of other HTML tags to run JavaScript. Version 11.0.0 fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| haxtheweb | issues | before 11.0.0 | 11.0.0 | Patch available | CNA |
| — | elmsln/haxcms (Packagist) | before 11.0.0 | 11.0.0 | Patch available | GHSA-2vc4-3hx7-v7v7 |
- issues Vendorhaxtheweb Affected before 11.0.0 Fixed in 11.0.0 Patch available CNA
- elmsln/haxcms (Packagist) Vendor— Affected before 11.0.0 Fixed in 11.0.0 Patch available GHSA-2vc4-3hx7-v7v7
Remediation
- Fix · CNA issues (haxtheweb) Fixed in 11.0.0
- Fix · GHSA-2vc4-3hx7-v7v7 elmsln/haxcms (Packagist) Fixed in 11.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-49137
- 2026-10-03 Alias added: GHSA-2vc4-3hx7-v7v7
References
More haxtheweb Haxcms-nodejs vulnerabilities
- TI-2025-33970 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access CVSS 4.0CRITICAL 9.3
- TI-2025-31221 HaxCMS-PHP Command Injection Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-34187 HAX CMS Backend Lacks Comprehensive Authorization Checks CVSS 3.1HIGH 8.3
- TI-2025-33971 HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting CVSS 4.0HIGH 7.2
- TI-2025-33977 HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service CVSS 4.0HIGH 7.1
- TI-2025-31219 @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-49137 · CVE Program
- CVE-2025-49137 · NVD
- FIRST EPSS
- GHSA-2vc4-3hx7-v7v7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences