HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| haxtheweb | issues | before 11.0.8 | 11.0.8 | Patch available | CNA |
| — | @haxtheweb/haxcms-nodejs (npm) | before 11.0.8 | 11.0.8 | Patch available | GHSA-59g8-h59f-8hjp |
- issues Vendorhaxtheweb Affected before 11.0.8 Fixed in 11.0.8 Patch available CNA
- @haxtheweb/haxcms-nodejs (npm) Vendor— Affected before 11.0.8 Fixed in 11.0.8 Patch available GHSA-59g8-h59f-8hjp
Remediation
- Fix · CNA issues (haxtheweb) Fixed in 11.0.8
- Fix · GHSA-59g8-h59f-8hjp @haxtheweb/haxcms-nodejs (npm) Fixed in 11.0.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54128
- 2026-10-03 Alias added: GHSA-59g8-h59f-8hjp
References
More haxtheweb Haxcms-nodejs vulnerabilities
- TI-2025-33970 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access CVSS 4.0CRITICAL 9.3
- TI-2025-31221 HaxCMS-PHP Command Injection Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-34187 HAX CMS Backend Lacks Comprehensive Authorization Checks CVSS 3.1HIGH 8.3
- TI-2025-31217 Hax CMS Stored Cross-Site Scripting vulnerability CVSS 3.1HIGH 8.5
- TI-2025-33977 HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service CVSS 4.0HIGH 7.1
- TI-2025-31219 @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-54128 · CVE Program
- CVE-2025-54128 · NVD
- FIRST EPSS
- GHSA-59g8-h59f-8hjp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences