HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.
Summary
HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.8 and below, the HAX CMS NodeJS application crashes when an authenticated attacker provides an API request lacking required URL parameters. This vulnerability affects the listFiles and saveFiles endpoints. This vulnerability exists because the application does not properly handle exceptions which occur as a result of changes to user-modifiable URL parameters. This is fixed in version 11.0.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| haxtheweb | issues | before 11.0.9 | 11.0.9 | Patch available | CNA |
| — | @haxtheweb/haxcms-nodejs (npm) | before 11.0.9 | 11.0.9 | Patch available | GHSA-pjj3-j5j6-qj27 |
- issues Vendorhaxtheweb Affected before 11.0.9 Fixed in 11.0.9 Patch available CNA
- @haxtheweb/haxcms-nodejs (npm) Vendor— Affected before 11.0.9 Fixed in 11.0.9 Patch available GHSA-pjj3-j5j6-qj27
Remediation
- Fix · CNA issues (haxtheweb) Fixed in 11.0.9
- Fix · GHSA-pjj3-j5j6-qj27 @haxtheweb/haxcms-nodejs (npm) Fixed in 11.0.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54134
- 2026-10-03 Alias added: GHSA-pjj3-j5j6-qj27
References
Advisory 2
More haxtheweb Haxcms-nodejs vulnerabilities
- TI-2025-33970 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access CVSS 4.0CRITICAL 9.3
- TI-2025-31221 HaxCMS-PHP Command Injection Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-34187 HAX CMS Backend Lacks Comprehensive Authorization Checks CVSS 3.1HIGH 8.3
- TI-2025-31217 Hax CMS Stored Cross-Site Scripting vulnerability CVSS 3.1HIGH 8.5
- TI-2025-33971 HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting CVSS 4.0HIGH 7.2
- TI-2025-31219 @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-54134 · CVE Program
- CVE-2025-54134 · NVD
- FIRST EPSS
- GHSA-pjj3-j5j6-qj27 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences