@haxtheweb/haxcms-nodejs Iframe Phishing vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1021.
Summary
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, in the HAX site editor, users can create a website block to load another site in an iframe. The application allows users to supply a target URL in the website block. When the HAX site is visited, the client's browser will query the supplied URL. An authenticated attacker can create a HAX site with a website block pointing at an attacker-controlled server running Responder or a similar tool. The attacker can then conduct a phishing attack by convincing another user to visit their malicious HAX site to harvest credentials. Version 11.0.0 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| haxtheweb | issues | before 11.0.0 | 11.0.0 | Patch available | CNA |
| — | @haxtheweb/haxcms-nodejs (npm) | before 11.0.0 | 11.0.0 | Patch available | GHSA-v3ph-2q5q-cg88 |
- issues Vendorhaxtheweb Affected before 11.0.0 Fixed in 11.0.0 Patch available CNA
- @haxtheweb/haxcms-nodejs (npm) Vendor— Affected before 11.0.0 Fixed in 11.0.0 Patch available GHSA-v3ph-2q5q-cg88
Remediation
- Fix · CNA issues (haxtheweb) Fixed in 11.0.0
- Fix · GHSA-v3ph-2q5q-cg88 @haxtheweb/haxcms-nodejs (npm) Fixed in 11.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-49139
- 2026-10-03 Alias added: GHSA-v3ph-2q5q-cg88
References
More haxtheweb Haxcms-nodejs vulnerabilities
- TI-2025-33970 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access CVSS 4.0CRITICAL 9.3
- TI-2025-31221 HaxCMS-PHP Command Injection Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-34187 HAX CMS Backend Lacks Comprehensive Authorization Checks CVSS 3.1HIGH 8.3
- TI-2025-31217 Hax CMS Stored Cross-Site Scripting vulnerability CVSS 3.1HIGH 8.5
- TI-2025-33971 HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting CVSS 4.0HIGH 7.2
- TI-2025-33977 HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service CVSS 4.0HIGH 7.1
Sources
- CVE-2025-49139 · CVE Program
- CVE-2025-49139 · NVD
- FIRST EPSS
- GHSA-v3ph-2q5q-cg88 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences