HaxCMS-PHP Command Injection Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.3, the `gitImportSite` functionality obtains a URL string from a POST request and insufficiently validates user input. The `set_remote` function later passes this input into `proc_open`, yielding OS command injection. An authenticated attacker can craft a URL string that bypasses the validation checks employed by the `filter_var` and `strpos` functions in order to execute arbitrary OS commands on the backend server. The attacker can exfiltrate command output via an HTTP request. Version 11.0.3 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| haxtheweb | issues | before 11.0.3 | 11.0.3 | Patch available | CNA |
| — | @haxtheweb/haxcms-nodejs (npm) | before 11.0.3 | 11.0.3 | Patch available | GHSA-g4cf-pp4x-hqgw |
- issues Vendorhaxtheweb Affected before 11.0.3 Fixed in 11.0.3 Patch available CNA
- @haxtheweb/haxcms-nodejs (npm) Vendor— Affected before 11.0.3 Fixed in 11.0.3 Patch available GHSA-g4cf-pp4x-hqgw
Remediation
- Fix · CNA issues (haxtheweb) Fixed in 11.0.3
- Fix · GHSA-g4cf-pp4x-hqgw @haxtheweb/haxcms-nodejs (npm) Fixed in 11.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-49141
- 2026-10-03 Alias added: GHSA-g4cf-pp4x-hqgw
References
More haxtheweb Haxcms-nodejs vulnerabilities
- TI-2025-33970 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access CVSS 4.0CRITICAL 9.3
- TI-2025-34187 HAX CMS Backend Lacks Comprehensive Authorization Checks CVSS 3.1HIGH 8.3
- TI-2025-31217 Hax CMS Stored Cross-Site Scripting vulnerability CVSS 3.1HIGH 8.5
- TI-2025-33971 HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting CVSS 4.0HIGH 7.2
- TI-2025-33977 HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service CVSS 4.0HIGH 7.1
- TI-2025-31219 @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-49141 · CVE Program
- CVE-2025-49141 · NVD
- FIRST EPSS
- GHSA-g4cf-pp4x-hqgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences