Read the docs
TI-2025-34187 Aliases CVE-2025-54378GHSA-9jr9-8ff3-m894

HAX CMS Backend Lacks Comprehensive Authorization Checks

Priority HIGH 71CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

HAX CMS allows you to manage your microsite universe with PHP or NodeJs backends. In versions 11.0.13 and below of haxcms-nodejs and versions 11.0.8 and below of haxcms-php, API endpoints do not perform authorization checks when interacting with a resource. Both the JS and PHP versions of the CMS do not verify that a user has permission to interact with a resource before performing a given operation. The API endpoints within the HAX CMS application check if a user is authenticated, but don't check for authorization before performing an operation. This is fixed in versions 11.0.14 of haxcms-nodejs and 11.0.9 of haxcms-php.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0057 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed issues (haxtheweb): 11.0.14@haxtheweb/haxcms-nodejs (npm): 11.0.14+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
haxthewebissuesbefore 11.0.1411.0.14Patch availableCNA
—@haxtheweb/haxcms-nodejs (npm)before 11.0.1411.0.14Patch availableGHSA-9jr9-8ff3-m894
—elmsln/haxcms (Packagist)before 11.0.1411.0.14Patch availableGHSA-9jr9-8ff3-m894
  • issues Vendorhaxtheweb Affected before 11.0.14 Fixed in 11.0.14 Patch available CNA
  • @haxtheweb/haxcms-nodejs (npm) Vendor— Affected before 11.0.14 Fixed in 11.0.14 Patch available GHSA-9jr9-8ff3-m894
  • elmsln/haxcms (Packagist) Vendor— Affected before 11.0.14 Fixed in 11.0.14 Patch available GHSA-9jr9-8ff3-m894

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:psu:haxcms-nodejs:*:*:*:*:*:node.js:*:*before 11.0.14Vulnerablehaxtheweb
cpe:2.3:a:psu:haxcms-php:*:*:*:*:*:*:*:*before 11.0.9Vulnerablehaxtheweb
  • cpe:2.3:a:psu:haxcms-nodejs:*:*:*:*:*:node.js:*:* Versions before 11.0.14 Vulnerable ·haxtheweb
  • cpe:2.3:a:psu:haxcms-php:*:*:*:*:*:*:*:* Versions before 11.0.9 Vulnerable ·haxtheweb

Remediation

  • Fix · CNA issues (haxtheweb) Fixed in 11.0.14
  • Fix · GHSA-9jr9-8ff3-m894 @haxtheweb/haxcms-nodejs (npm) Fixed in 11.0.14 Advisory →
  • Fix · GHSA-9jr9-8ff3-m894 elmsln/haxcms (Packagist) Fixed in 11.0.14 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-54378
  2. 2026-10-03 Alias added: GHSA-9jr9-8ff3-m894

References

  • TI-2025-33970 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access CVSS 4.0CRITICAL 9.3
  • TI-2025-31221 HaxCMS-PHP Command Injection Vulnerability CVSS 3.1HIGH 8.8
  • TI-2025-31217 Hax CMS Stored Cross-Site Scripting vulnerability CVSS 3.1HIGH 8.5
  • TI-2025-33971 HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting CVSS 4.0HIGH 7.2
  • TI-2025-33977 HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service CVSS 4.0HIGH 7.1
  • TI-2025-31219 @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability CVSS 3.1MEDIUM 6.5
See all 10 →

Sources