HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover
Priority LOW 39CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01026 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed issues (haxtheweb): 25.0.0@haxtheweb/haxcms-nodejs (npm): 25.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| haxtheweb | issues | 11.0.6 to before 25.0.0 | 25.0.0 | Patch available | CNA |
| — | @haxtheweb/haxcms-nodejs (npm) | 11.0.6 to before 25.0.0 | 25.0.0 | Patch available | GHSA-3fm2-xfq7-7778 |
- issues Vendorhaxtheweb Affected 11.0.6 to before 25.0.0 Fixed in 25.0.0 Patch available CNA
- @haxtheweb/haxcms-nodejs (npm) Vendor— Affected 11.0.6 to before 25.0.0 Fixed in 25.0.0 Patch available GHSA-3fm2-xfq7-7778
Remediation
- Fix · CNA issues (haxtheweb) Fixed in 25.0.0
- Fix · GHSA-3fm2-xfq7-7778 @haxtheweb/haxcms-nodejs (npm) Fixed in 25.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22704
- 2026-10-03 Alias added: GHSA-3fm2-xfq7-7778
References
More haxtheweb Haxcms-nodejs vulnerabilities
- TI-2025-33970 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access CVSS 4.0CRITICAL 9.3
- TI-2025-31221 HaxCMS-PHP Command Injection Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-34187 HAX CMS Backend Lacks Comprehensive Authorization Checks CVSS 3.1HIGH 8.3
- TI-2025-31217 Hax CMS Stored Cross-Site Scripting vulnerability CVSS 3.1HIGH 8.5
- TI-2025-33971 HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting CVSS 4.0HIGH 7.2
- TI-2025-33977 HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service CVSS 4.0HIGH 7.1
Sources
- CVE-2026-22704 · CVE Program
- CVE-2026-22704 · NVD
- FIRST EPSS
- GHSA-3fm2-xfq7-7778 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences