LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-22 and the CVSS impact.
Summary
LangChain is a framework for building agents and LLM-powered applications. Prior to 1.3.9, several LangChain components that resolve filesystem paths or expand search patterns do not consistently confine the resolved path to the intended root directory. Affected behaviors include: a file-search agent middleware that validates a starting directory but not the search pattern or the resolved target of matched files, so glob patterns and symlinks can reach files outside the configured root; prompt- and chain/agent-configuration loaders that accept path fields and resolve them without confining the result to a trusted base or rejecting symlink targets; and path-prefix authorization checks that compare by string prefix without a path-segment boundary, so a sibling path sharing the prefix is accepted. When these components receive path values, search patterns, or workspace contents influenced by an untrusted source — including an LLM acting on untrusted input — the result can be disclosure of files outside the intended boundary. This vulnerability is fixed in 1.3.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| langchain-ai | langchain | before 1.3.9 | 1.3.9 | Patch available | CNA |
| langchain-ai | langchain-anthropic | before 1.4.6 | 1.4.6 | Patch available | CNA |
| — | langchain (PyPI) | before 1.3.9 | 1.3.9 | Patch available | GHSA-gr75-jv2w-4656 |
| — | langchain-anthropic (PyPI) | before 1.4.6 | 1.4.6 | Patch available | GHSA-gr75-jv2w-4656 |
- langchain Vendorlangchain-ai Affected before 1.3.9 Fixed in 1.3.9 Patch available CNA
- langchain-anthropic Vendorlangchain-ai Affected before 1.4.6 Fixed in 1.4.6 Patch available CNA
- langchain (PyPI) Vendor— Affected before 1.3.9 Fixed in 1.3.9 Patch available GHSA-gr75-jv2w-4656
- langchain-anthropic (PyPI) Vendor— Affected before 1.4.6 Fixed in 1.4.6 Patch available GHSA-gr75-jv2w-4656
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:* | before 1.3.9 | Vulnerable | langchain-ai |
- cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:* Versions before 1.3.9 Vulnerable ·langchain-ai
Remediation
- Fix · CNA langchain (langchain-ai) Fixed in 1.3.9
- Fix · CNA langchain-anthropic (langchain-ai) Fixed in 1.4.6
- Fix · GHSA-gr75-jv2w-4656 langchain (PyPI) Fixed in 1.3.9 Advisory →
- Fix · GHSA-gr75-jv2w-4656 langchain-anthropic (PyPI) Fixed in 1.4.6 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Exploit Intelligence | Affected | — |
| Migration Toolkit for Applications 8 | Affected | No fix yet: Fix deferred |
| Red Hat Ansible Automation Platform 2 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet: Fix deferred |
Not affected: 3 products
- Ansible Automation Orchestrator 2026
- OpenShift Lightspeed
- Red Hat OpenShift AI (RHOAI)
Timeline
- 2026-10-02 Threatist record created from CVE-2026-55443
- 2026-10-03 Alias added: GHSA-gr75-jv2w-4656
- 2026-11-06 Affected versions changed · Red Hat
- 2026-11-06 CVSS score added · Red Hat
References
More langchain-ai Langchain vulnerabilities
- TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
- TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
- TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-55443 · CVE Program
- CVE-2026-55443 · NVD
- FIRST EPSS
- GHSA-gr75-jv2w-4656 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-55443 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences