WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress | 6.8.0 to before 6.8.6; 6.9.0 to before 6.9.5; 7.0.0 to before 7.0.2 | 6.8.6, 6.9.5, 7.0.2 | Patch available | CNA |
- WordPress VendorWordPress Affected 6.8.0 to before 6.8.6; 6.9.0 to before 6.9.5; 7.0.0 to before 7.0.2 Fixed in 6.8.6, 6.9.5, 7.0.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | 6.8 to before 6.8.6; 6.9 to before 6.9.5; 7.0 to before 7.0.2 | Vulnerable | WordPress |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions 6.8 to before 6.8.6; 6.9 to before 6.9.5; 7.0 to before 7.0.2 Vulnerable ·WordPress
Remediation
- Fix · CNA WordPress (WordPress) Fixed in 6.8.6, 6.9.5, 7.0.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
WordPress — wordpress.org/news/2026/07/wordpress-7-0-2-release
2 records Highest priority Priority CRITICAL 2 CRITICAL
Other records, highest priority first
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code ExecutionPriority CRITICAL 100
Timeline
- 2026-07-21 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2026-60137
References
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2022-06039 SQL injection in WordPress CVSS 3.1HIGH 8.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences