Priority CRITICAL 100KEV
WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.10649 · Published 2026-07-17 · Fixed in 6.9.5, 7.0.2 CWE-436
Priority CRITICAL 100KEV
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote)…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.99714 · Published 2016-12-30 · Fixed in 5.2.18 CWE-88
Priority CRITICAL 94KEV
WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.01157 · Published 2026-10-31 · No fix listed CWE-367
Priority CRITICAL 94KEV
An unauthenticated attacker can make `get_page_template()` page-template resolution include a chosen readable local `.php` file outside the active theme directories.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.95769 · Published 2026-09-22 · Fixed in 7.1.2 CWE-98
Priority CRITICAL 87
The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshell…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.97738 · Published 2016-12-30 · Fixed in 5.2.20 CWE-77
Priority CRITICAL 86KEV
WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input…
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.05323 · Published 2026-07-17 · Fixed in 6.8.6, 6.9.5 +1 CWE-89
Priority HIGH 81
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database.
CVSS 3.1HIGH 8.0· Network · High privileges · No interaction · EPSS 0.97795 · Published 2022-01-06 · Fixed in 5.8.3 CWE-89
Priority HIGH 79
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.82736 · Published 2019-02-20 · No fix listed CWE-434
Priority HIGH 75
WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name.
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.71024 · Published 2024-05-03 · No fix listed CWE-80
Priority HIGH 74
The register_routes function in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in the REST API in WordPress 4.7.x before 4.7.2 does not require an integer identifier, which allows remote attackers to m…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.84935 · Published 2017-04-03 · No fix listed
Priority HIGH 73
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database.
CVSS 3.1HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.64529 · Published 2022-01-06 · Fixed in 5.8.3 CWE-79
Priority HIGH 73
Wordpress is an open source CMS.
CVSS 3.1HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.85719 · Published 2021-04-15 · Fixed in 5.7.1 CWE-611
Priority HIGH 73
WordPress through 4.9.6 allows Author users to execute arbitrary code by leveraging directory traversal in the wp-admin/post.php thumb parameter, which is passed to the PHP unlink function and can delete the wp-config.ph…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.62162 · Published 2018-06-26 · No fix listed CWE-22
Priority HIGH 72
WordPress through 5.0.3 allows Path Traversal in wp_crop_image().
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.91985 · Published 2019-02-20 · No fix listed CWE-22
Priority HIGH 71
In WordPress through 4.9.2, unauthenticated attackers can cause a denial of service (resource consumption) by using the large list of registered .js files (from wp-includes/script-loader.php) to construct a series of req…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.72671 · Published 2018-02-06 · No fix listed CWE-400
Priority HIGH 67
WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.79657 · Published 2023-05-17 · Fixed in 4.1.38, 4.2.35 +20 CWE-22
Priority HIGH 67
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.03816 · Published 2022-01-06 · Fixed in 5.8.3 CWE-74
Priority HIGH 66
wp-includes/rest-api/endpoints/class-wp-rest-users-controller.php in the REST API implementation in WordPress 4.7 before 4.7.1 does not properly restrict listings of post authors, which allows remote attackers to obtain…
CVSS 3.0MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.87299 · Published 2017-01-15 · No fix listed CWE-200
Priority HIGH 66
wp-admin/setup-config.php in the installation component in WordPress 3.3.1 and earlier does not ensure that the specified MySQL database service is appropriate, which allows remote attackers to configure an arbitrary dat…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.09023 · Published 2012-01-30 · No fix listed
Priority HIGH 65
WordPress before 5.8 lacks support for the Update URI plugin header.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.28983 · Published 2021-11-25 · No fix listed
Priority HIGH 65
WordPress before 5.1.1 does not properly filter comment content, leading to Remote Code Execution by unauthenticated users in a default configuration.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.38557 · Published 2019-03-14 · No fix listed CWE-352
Priority MEDIUM 64
In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.26819 · Published 2018-12-14 · No fix listed CWE-502
Priority MEDIUM 64
wp-includes/class-phpass.php in WordPress before 3.7.5, 3.8.x before 3.8.5, 3.9.x before 3.9.3, and 4.x before 4.0.1 allows remote attackers to cause a denial of service (CPU consumption) via a long password that is impr…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.83237 · Published 2014-11-25 · No fix listed CWE-19
Priority MEDIUM 64
WordPress and WordPress MU before 2.8.1 exhibit different behavior for a failed login attempt depending on whether the user account exists, which allows remote attackers to enumerate valid usernames.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.85 · Published 2009-07-10 · No fix listed CWE-16
Priority MEDIUM 63
WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website vi…
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.04335 · Published 2023-10-16 · Fixed in 6.3.2, 6.2.3 +14
Load more