n8n before 1.123.64, 2.29.8, and 2.30.1 SSRF via Dynamic Node Parameters
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
n8n versions before 1.123.64, 2.29.8, and 2.30.1 contain a server-side request forgery vulnerability in the dynamic-node-parameters endpoints that lack authorization scopes. Authenticated attackers can supply absolute URLs in routing configuration to override baseURL restrictions and make the n8n server issue HTTP requests to arbitrary internal targets when SSRF protection is disabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.64 | 1.123.64 | Patch available | CNA |
| n8n | n8n | 2.30.0 to before 2.30.1 | 2.30.1 | Patch available | CNA |
| n8n | n8n | 2.0.0-rc.0 to before 2.29.8 | 2.29.8 | Patch available | CNA |
| — | n8n (npm) | before 1.123.64 | 1.123.64 | Patch available | GHSA-9w78-79q7-r4fp |
| — | n8n (npm) | 2.30.0 to before 2.30.1 | 2.30.1 | Patch available | GHSA-9w78-79q7-r4fp |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.29.8 | 2.29.8 | Patch available | GHSA-9w78-79q7-r4fp |
- n8n Vendorn8n Affected before 1.123.64 Fixed in 1.123.64 Patch available CNA
- n8n Vendorn8n Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available CNA
- n8n Vendorn8n Affected 2.0.0-rc.0 to before 2.29.8 Fixed in 2.29.8 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.64 Fixed in 1.123.64 Patch available GHSA-9w78-79q7-r4fp
- n8n (npm) Vendor— Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available GHSA-9w78-79q7-r4fp
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.29.8 Fixed in 2.29.8 Patch available GHSA-9w78-79q7-r4fp
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | before 1.123.64 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | before 1.123.64 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | 2.0.0 to before 2.29.8 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | 2.0.0 to before 2.29.8 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:* | 2.30.0 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:* | 2.30.0 | Vulnerable | n8n |
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 1.123.64 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions before 1.123.64 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions 2.0.0 to before 2.29.8 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions 2.0.0 to before 2.29.8 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:* Versions 2.30.0 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:* Versions 2.30.0 Vulnerable ·n8n
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.123.64
- Fix · CNA n8n (n8n-io) Fixed in 2.30.1
- Fix · CNA n8n (n8n-io) Fixed in 2.29.8
- Fix · GHSA-9w78-79q7-r4fp n8n (npm) Fixed in 1.123.64 Advisory →
- Fix · GHSA-9w78-79q7-r4fp n8n (npm) Fixed in 2.30.1 Advisory →
- Fix · GHSA-9w78-79q7-r4fp n8n (npm) Fixed in 2.29.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
n8n-io n8n 2.29.8, 2.30.1
13 records Highest priority Priority MEDIUM 3 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2026-46758 n8n before 2.29.8 and 2.30.1 Privilege Escalation via Token ExchangePriority MEDIUM 42
- TI-2026-46754 n8n before 1.123.64 Sanitizer Bypass Remote Code ExecutionPriority MEDIUM 42
- TI-2026-46761 n8n before 1.123.64 Remote Code Execution via Git ClonePriority MEDIUM 40
- Release ·
n8n-io n8n 1.123.64
9 records Highest priority Priority MEDIUM 2 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2026-46754 n8n before 1.123.64 Sanitizer Bypass Remote Code ExecutionPriority MEDIUM 42
- TI-2026-46761 n8n before 1.123.64 Remote Code Execution via Git ClonePriority MEDIUM 40
- TI-2026-46755 n8n before 1.123.64 Stored DOM XSS via cachedResultUrlPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-65593
- 2026-10-03 Alias added: GHSA-9w78-79q7-r4fp
- 2026-10-29 Affected versions changed · CNA
References
Advisory 2
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-65593 · CVE Program
- CVE-2026-65593 · NVD
- FIRST EPSS
- GHSA-9w78-79q7-r4fp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences