n8n before 1.123.64, 2.29.8, and 2.30.1 Credential Exposure via JWT Header
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-312.
Summary
n8n versions before 1.123.64, 2.29.8, and 2.30.1 contain a credential exposure vulnerability: when configured with a Google Service Account key, the full PEM private key was mistakenly placed in the JWT header's kid field (intended only for a key identifier). Because JWT headers are Base64-encoded rather than encrypted, the private key could be recovered by anything that logged or inspected the JWT. An attacker who obtained the key could impersonate the service account and access or modify any Google Cloud resource it was authorized to use. Only instances using Google Service Account credentials are affected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.64 | 1.123.64 | Patch available | CNA |
| n8n | n8n | 2.30.0 to before 2.30.1 | 2.30.1 | Patch available | CNA |
| n8n | n8n | 2.0.0-rc.0 to before 2.29.8 | 2.29.8 | Patch available | CNA |
| — | n8n (npm) | before 1.123.64 | 1.123.64 | Patch available | GHSA-9r8p-h6cc-6qhm |
| — | n8n (npm) | 2.30.0 to before 2.30.1 | 2.30.1 | Patch available | GHSA-9r8p-h6cc-6qhm |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.29.8 | 2.29.8 | Patch available | GHSA-9r8p-h6cc-6qhm |
- n8n Vendorn8n Affected before 1.123.64 Fixed in 1.123.64 Patch available CNA
- n8n Vendorn8n Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available CNA
- n8n Vendorn8n Affected 2.0.0-rc.0 to before 2.29.8 Fixed in 2.29.8 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.64 Fixed in 1.123.64 Patch available GHSA-9r8p-h6cc-6qhm
- n8n (npm) Vendor— Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available GHSA-9r8p-h6cc-6qhm
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.29.8 Fixed in 2.29.8 Patch available GHSA-9r8p-h6cc-6qhm
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | before 1.123.64 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | before 1.123.64 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | 2.0.0 to before 2.29.8 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | 2.0.0 to before 2.29.8 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:* | 2.30.0 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:* | 2.30.0 | Vulnerable | n8n |
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 1.123.64 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions before 1.123.64 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions 2.0.0 to before 2.29.8 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions 2.0.0 to before 2.29.8 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:* Versions 2.30.0 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:* Versions 2.30.0 Vulnerable ·n8n
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.123.64
- Fix · CNA n8n (n8n-io) Fixed in 2.30.1
- Fix · CNA n8n (n8n-io) Fixed in 2.29.8
- Fix · GHSA-9r8p-h6cc-6qhm n8n (npm) Fixed in 1.123.64 Advisory →
- Fix · GHSA-9r8p-h6cc-6qhm n8n (npm) Fixed in 2.30.1 Advisory →
- Fix · GHSA-9r8p-h6cc-6qhm n8n (npm) Fixed in 2.29.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
n8n-io n8n 2.29.8, 2.30.1
13 records Highest priority Priority MEDIUM 3 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2026-46758 n8n before 2.29.8 and 2.30.1 Privilege Escalation via Token ExchangePriority MEDIUM 42
- TI-2026-46754 n8n before 1.123.64 Sanitizer Bypass Remote Code ExecutionPriority MEDIUM 42
- TI-2026-46761 n8n before 1.123.64 Remote Code Execution via Git ClonePriority MEDIUM 40
- Release ·
n8n-io n8n 1.123.64
9 records Highest priority Priority MEDIUM 2 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2026-46754 n8n before 1.123.64 Sanitizer Bypass Remote Code ExecutionPriority MEDIUM 42
- TI-2026-46761 n8n before 1.123.64 Remote Code Execution via Git ClonePriority MEDIUM 40
- TI-2026-46755 n8n before 1.123.64 Stored DOM XSS via cachedResultUrlPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-65599
- 2026-10-03 Alias added: GHSA-9r8p-h6cc-6qhm
- 2026-10-29 Affected versions changed · CNA
References
Advisory 2
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-65599 · CVE Program
- CVE-2026-65599 · NVD
- FIRST EPSS
- GHSA-9r8p-h6cc-6qhm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences