Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

357 records

Priority CRITICAL 100KEV

WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.10649 Published 2026-07-17 Fixed in 6.9.5, 7.0.2 CWE-436
Priority CRITICAL 86KEV

WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input…

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.05323 Published 2026-07-17 Fixed in 6.8.6, 6.9.5 +1 CWE-89
Priority LOW 25

WordPress Core, in versions up to 6.0.2, is vulnerable to Authenticated Stored Cross-Site Scripting that can be exploited by users with access to the WordPress post and page editor, typically consisting of Authors, Contr…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00449 Published 2024-10-16 No fix listed CWE-79
TI-2024-04129 CVE-2024-4439 · GHSA-682x-vcqv-v7v6

Cross-site scripting in WordPress

Priority HIGH 75

WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name.

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.71024 Published 2024-05-03 No fix listed CWE-80
Priority MEDIUM 63

WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website vi…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.04335 Published 2023-10-16 Fixed in 6.3.2, 6.2.3 +14
Priority LOW 22

Exposure of Sensitive Information to an Unauthorized Actor in WordPress from 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.13, from 6.0 through 6.0.5, from 5.9 through 5.9.7, from 5.8 through 5.8.7, from…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.0119 Published 2023-10-13 No fix listed CWE-200
Priority LOW 30

Auth. Stored (contributor+) Cross-Site Scripting (XSS) vulnerability in WordPress core 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.1.3, from 6.0 through 6.0.5, from 5.9 through 5.9.7 and Gutenberg plugi…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00872 Published 2023-10-13 No fix listed CWE-79
Priority HIGH 67

WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.79657 Published 2023-05-17 Fixed in 4.1.38, 4.2.35 +20 CWE-22
Priority LOW 28

WordPress through 6.1.1 depends on unpredictable client visits to cause wp-cron.php execution and the resulting security updates, and the source code describes "the scenario where a site may not receive enough visits to…

CVSS 3.1MEDIUM 5.3 Adjacent network No auth No interaction EPSS 0.01731 Published 2023-01-05 No fix listed
TI-2022-21288 CVE-2022-43504 · GHSA-h8vf-v4qw-mvq4

Improper authentication in WordPress

Priority LOW 33

Improper authentication vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to obtain the email address of the user who posted a blog using the WordPress Post by Email Feature.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.01499 Published 2022-12-05 Fixed in 6.0.3 CWE-287
TI-2022-21286 CVE-2022-43500 · GHSA-hm6q-fjph-v26v

Cross-site scripting in WordPress

Priority LOW 29

Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00977 Published 2022-12-05 Fixed in 6.0.3 CWE-79
TI-2022-21284 CVE-2022-43497 · GHSA-rvwm-8qg8-4hp8

Cross-site scripting in WordPress

Priority LOW 30

Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01256 Published 2022-12-05 Fixed in 6.0.3 CWE-79
TI-2011-01541 CVE-2011-1762 · GHSA-fp52-jqr7-7249

Improper access control in wordpress

Priority LOW 30

A flaw exists in Wordpress related to the 'wp-admin/press-this.php 'script improperly checking user permissions when publishing posts.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00733 Published 2022-04-18 No fix listed CWE-284
Priority HIGH 73

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database.

CVSS 3.1HIGH 8.0 Network Low privileges User interaction EPSS 0.64529 Published 2022-01-06 Fixed in 5.8.3 CWE-79
Priority MEDIUM 44

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.03674 Published 2022-01-06 Fixed in 5.8.3 CWE-89
Priority HIGH 81

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database.

CVSS 3.1HIGH 8.0 Network High privileges No interaction EPSS 0.97795 Published 2022-01-06 Fixed in 5.8.3 CWE-89
Load more