WordPress Core < 6.2.1 - Directory Traversal
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafted translation file onto the site, such as via an upload form, this could be also used to perform a Cross-Site Scripting attack.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress | before 4.1.38; 4.2 to before 4.2.35; 4.3 to before 4.3.31; 4.4 to before 4.4.30; 4.5 to before 4.5.29; 4.6 to before 4.6.26; 4.7 to before 4.7.26; 4.8 to before 4.8.22; 4.9 to before 4.9.23; 5.0 to before 5.0.19; 5.1 to before 5.1.16; 5.2 to before 5.2.18; 5.3 to before 5.3.15; 5.4 to before 5.4.13; 5.5 to before 5.5.12; 5.6 to before 5.6.11; 5.7 to before 5.7.9; 5.8 to before 5.8.7; 5.9 to before 5.9.6; 6.0 to before 6.0.4; 6.1 to before 6.1.2; 6.2 to before 6.2.1 | 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1 | Patch available | CNA |
- WordPress VendorWordPress Affected before 4.1.38; 4.2 to before 4.2.35; 4.3 to before 4.3.31; 4.4 to before 4.4.30; 4.5 to before 4.5.29; 4.6 to before 4.6.26; 4.7 to before 4.7.26; 4.8 to before 4.8.22; 4.9 to before 4.9.23; 5.0 to before 5.0.19; 5.1 to before 5.1.16; 5.2 to before 5.2.18; 5.3 to before 5.3.15; 5.4 to before 5.4.13; 5.5 to before 5.5.12; 5.6 to before 5.6.11; 5.7 to before 5.7.9; 5.8 to before 5.8.7; 5.9 to before 5.9.6; 6.0 to before 6.0.4; 6.1 to before 6.1.2; 6.2 to before 6.2.1 Fixed in 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | before 4.1.38; 4.2 to before 4.2.35; 4.3 to before 4.3.31; 4.4 to before 4.4.30; 4.5 to before 4.5.29; 4.6 to before 4.6.26; 4.7 to before 4.7.26; 4.8 to before 4.8.22; 4.9 to before 4.9.23; 5.0 to before 5.0.19; 5.1 to before 5.1.16; 5.2 to before 5.2.18; 5.3 to before 5.3.15; 5.4 to before 5.4.13; 5.5 to before 5.5.12; 5.6 to before 5.6.11; 5.7 to before 5.7.9; 5.8 to before 5.8.7; 5.9 to before 5.9.6; 6.0 to before 6.0.4; 6.1 to before 6.1.2 | Vulnerable | WordPress |
| cpe:2.3:a:wordpress:wordpress:6.2:*:*:*:*:*:*:* | 6.2 | Vulnerable | WordPress |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions before 4.1.38; 4.2 to before 4.2.35; 4.3 to before 4.3.31; 4.4 to before 4.4.30; 4.5 to before 4.5.29; 4.6 to before 4.6.26; 4.7 to before 4.7.26; 4.8 to before 4.8.22; 4.9 to before 4.9.23; 5.0 to before 5.0.19; 5.1 to before 5.1.16; 5.2 to before 5.2.18; 5.3 to before 5.3.15; 5.4 to before 5.4.13; 5.5 to before 5.5.12; 5.6 to before 5.6.11; 5.7 to before 5.7.9; 5.8 to before 5.8.7; 5.9 to before 5.9.6; 6.0 to before 6.0.4; 6.1 to before 6.1.2 Vulnerable ·WordPress
- cpe:2.3:a:wordpress:wordpress:6.2:*:*:*:*:*:*:* Versions 6.2 Vulnerable ·WordPress
Remediation
- Fix · CNA WordPress (WordPress Foundation) Fixed in 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, 4.6.26, 4.7.26, 4.8.22, 4.9.23, 5.0.19, 5.1.16, 5.2.18, 5.3.15, 5.4.13, 5.5.12, 5.6.11, 5.7.9, 5.8.7, 5.9.6, 6.0.4, 6.1.2, 6.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2745
- 2026-10-03 Alias added: GHSA-xgqr-2mpj-w9qv
References
Advisory 2
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2026-42844 WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query KEVCVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-2745 · CVE Program
- CVE-2023-2745 · NVD
- FIRST EPSS
- GHSA-xgqr-2mpj-w9qv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences