WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure
Priority MEDIUM 63Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.04335 91st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed WordPress (WordPress): 6.3.2, 6.2.3, 6.1.4 +13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress | 6.3.0 to before 6.3.2; 6.2.0 to before 6.2.3; 6.1.0 to before 6.1.4; 6.0.0 to before 6.0.6; 5.9.0 to before 5.9.8; 5.8.0 to before 5.8.8; 5.7.0 to before 5.7.10; 5.6.0 to before 5.6.12; 5.5.0 to before 5.5.13; 5.4.0 to before 5.4.14; 5.3.0 to before 5.3.16; 5.2.0 to before 5.2.19; 5.0.0 to before 5.0.20; 4.9.0 to before 4.9.24; 4.8.0 to before 4.8.23; 4.7.0 to before 4.7.27 | 6.3.2, 6.2.3, 6.1.4, 6.0.6, 5.9.8, 5.8.8, 5.7.10, 5.6.12, 5.5.13, 5.4.14, 5.3.16, 5.2.19, 5.0.20, 4.9.24, 4.8.23, 4.7.27 | Patch available | CNA |
- WordPress VendorWordPress Affected 6.3.0 to before 6.3.2; 6.2.0 to before 6.2.3; 6.1.0 to before 6.1.4; 6.0.0 to before 6.0.6; 5.9.0 to before 5.9.8; 5.8.0 to before 5.8.8; 5.7.0 to before 5.7.10; 5.6.0 to before 5.6.12; 5.5.0 to before 5.5.13; 5.4.0 to before 5.4.14; 5.3.0 to before 5.3.16; 5.2.0 to before 5.2.19; 5.0.0 to before 5.0.20; 4.9.0 to before 4.9.24; 4.8.0 to before 4.8.23; 4.7.0 to before 4.7.27 Fixed in 6.3.2, 6.2.3, 6.1.4, 6.0.6, 5.9.8, 5.8.8, 5.7.10, 5.6.12, 5.5.13, 5.4.14, 5.3.16, 5.2.19, 5.0.20, 4.9.24, 4.8.23, 4.7.27 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | 4.7 to before 4.7.27; 4.8 to before 4.8.23; 4.9 to before 4.9.24; 5.0 to before 5.0.20; 5.1 to before 5.1.17; 5.2 to before 5.2.19; 5.3 to before 5.3.16; 5.4 to before 5.4.14; 5.5 to before 5.5.13; 5.6 to before 5.6.12; 5.7 to before 5.7.10; 5.8 to before 5.8.8; 5.9 to before 5.9.8; 6.0 to before 6.0.6; 6.1 to before 6.1.4; 6.2 to before 6.2.3; 6.3 to before 6.3.2 | Vulnerable | WordPress |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions 4.7 to before 4.7.27; 4.8 to before 4.8.23; 4.9 to before 4.9.24; 5.0 to before 5.0.20; 5.1 to before 5.1.17; 5.2 to before 5.2.19; 5.3 to before 5.3.16; 5.4 to before 5.4.14; 5.5 to before 5.5.13; 5.6 to before 5.6.12; 5.7 to before 5.7.10; 5.8 to before 5.8.8; 5.9 to before 5.9.8; 6.0 to before 6.0.6; 6.1 to before 6.1.4; 6.2 to before 6.2.3; 6.3 to before 6.3.2 Vulnerable ·WordPress
Remediation
- Fix · CNA WordPress (WordPress) Fixed in 6.3.2, 6.2.3, 6.1.4, 6.0.6, 5.9.8, 5.8.8, 5.7.10, 5.6.12, 5.5.13, 5.4.14, 5.3.16, 5.2.19, 5.0.20, 4.9.24, 4.8.23, 4.7.27
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5561
- 2026-10-03 Alias added: GHSA-x7w6-3cp2-qjcv
- 2026-10-14 EPSS moved to the 90th–95th percentile
References
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2026-42844 WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query KEVCVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-5561 · CVE Program
- CVE-2023-5561 · NVD
- FIRST EPSS
- GHSA-x7w6-3cp2-qjcv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences