Cross-site scripting in WordPress
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01256 69th percentileScored 2026-11-07
Fix Fixed WordPress (WordPress.org): 6.0.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WordPress | WordPress | before 6.0.3 | 6.0.3 | Patch available | CNA |
- WordPress VendorWordPress Affected before 6.0.3 Fixed in 6.0.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* | before 3.7.40; 3.8 to before 3.8.40; 3.9 to before 3.9.39; 4.0 to before 4.0.37; 4.1 to before 4.1.37; 4.2 to before 4.2.34; 4.3 to before 4.3.30; 4.4 to before 4.4.29; 4.5 to before 4.5.28; 4.6 to before 4.6.25; 4.7 to before 4.7.25; 4.8 to before 4.8.21; 4.9 to before 4.9.22; 5.0 to before 5.0.18; 5.1 to before 5.1.15; 5.2 to before 5.2.17; 5.3 to before 5.3.14; 5.4 to before 5.4.12; 5.5 to before 5.5.11; 5.6 to before 5.6.10; 5.7 to before 5.7.8; 5.8 to before 5.8.6; 5.9 to before 5.9.5; 6.0 to before 6.0.3 | Vulnerable | WordPress |
- cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions before 3.7.40; 3.8 to before 3.8.40; 3.9 to before 3.9.39; 4.0 to before 4.0.37; 4.1 to before 4.1.37; 4.2 to before 4.2.34; 4.3 to before 4.3.30; 4.4 to before 4.4.29; 4.5 to before 4.5.28; 4.6 to before 4.6.25; 4.7 to before 4.7.25; 4.8 to before 4.8.21; 4.9 to before 4.9.22; 5.0 to before 5.0.18; 5.1 to before 5.1.15; 5.2 to before 5.2.17; 5.3 to before 5.3.14; 5.4 to before 5.4.12; 5.5 to before 5.5.11; 5.6 to before 5.6.10; 5.7 to before 5.7.8; 5.8 to before 5.8.6; 5.9 to before 5.9.5; 6.0 to before 6.0.3 Vulnerable ·WordPress
Remediation
- Fix · CNA WordPress (WordPress.org) Fixed in 6.0.3
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43497
- 2026-10-03 Alias added: GHSA-rvwm-8qg8-4hp8
References
More Wordpress vulnerabilities
- TI-2026-45010 WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-83466 Predictable staging paths let attackers run code in WordPress Core KEVCVSS 3.1HIGH 8.1
- TI-2026-59973 An unauthenticated attacker can make `get_page_template()` page-template resolution… KEVCVSS 3.1HIGH 8.1
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2026-42844 WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query KEVCVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-43497 · CVE Program
- CVE-2022-43497 · NVD
- FIRST EPSS
- GHSA-rvwm-8qg8-4hp8 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-43497 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences