Priority MEDIUM 41
ImpressCMS contains an authenticated remote code execution vulnerability in the custom tag module that allows authenticated administrators to execute arbitrary PHP code by storing a malicious payload in a custom tag with…
CVSS 4.0HIGH 8.6· Network · High privileges · No interaction · EPSS 0.01126 · Published 2026-08-14 · No fix listed CWE-94
Priority HIGH 73
ImpressCMS 1.4.2 contains a remote code execution vulnerability in the autotasks administrative interface that allows authenticated attackers to execute arbitrary PHP code by injecting malicious code into the sat_code pa…
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00569 · Published 2026-05-10 · No fix listed CWE-94
Priority MEDIUM 64
ImpressCMS 1.3.11 contains a time-based blind SQL injection vulnerability that allows authenticated attackers to manipulate database queries by injecting SQL code through the 'bid' parameter.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00342 · Published 2026-04-12 · No fix listed CWE-89
Priority HIGH 81
ImpressCMS 1.4.4 contains a file upload vulnerability with weak extension sanitization that allows attackers to upload potentially malicious files.
CVSS 4.0CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.01217 · Published 2026-01-13 · No fix listed CWE-434
Priority MEDIUM 55
A cross-site scripting (XSS) vulnerability in ImpressCMS v1.4.5 and before allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the smile_code parameter of the component /editprof…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00457 · Published 2023-07-13 · No fix listed CWE-79
Priority LOW 39
SQL Injection in ImpressCMS 1.4.3 and earlier allows remote attackers to inject into the code in unintended way, this allows an attacker to read and modify the sensitive information from the database used by the applicat…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.04131 · Published 2022-04-05 · No fix listed CWE-89
Priority MEDIUM 41
ImpressCMS before 1.4.3 allows libraries/image-editor/image-edit.php image_temp Directory Traversal.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.03236 · Published 2022-03-28 · Fixed in 1.4.3 CWE-22
Priority MEDIUM 51
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0563 · Published 2022-03-28 · Fixed in 1.4.3 CWE-843
Priority MEDIUM 61
ImpressCMS before 1.4.3 allows include/findusers.php groups SQL Injection.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.20968 · Published 2022-03-28 · Fixed in 1.4.3 CWE-89
Priority LOW 37
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.10528 · Published 2022-03-28 · Fixed in 1.4.3 CWE-287
Priority MEDIUM 51
ImpressCMS before 1.4.2 allows unauthenticated remote code execution via ...../// directory traversal in origName or imageName, leading to unsafe interaction with the CKEditor processImage.php script.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.06354 · Published 2022-02-13 · Fixed in 1.4.2 CWE-22
Priority LOW 26
Cross-site scripting (XSS) in modules/content/admin/content.php in ImpressCMS profile 1.4.2 allows remote attackers to inject arbitrary web script or HTML parameters through the "Display Name" field.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00867 · Published 2021-03-11 · No fix listed CWE-79
Priority LOW 24
ImpressCMS 1.4.0 is affected by XSS in modules/system/admin.php which may result in arbitrary remote code execution.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.01134 · Published 2020-10-07 · Fixed in 1.4.1 CWE-79
Priority LOW 30
ImpressCMS 1.3.10 has XSS via the PATH_INFO to htdocs/install/index.php, htdocs/install/page_langselect.php, or htdocs/install/page_modcheck.php.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01548 · Published 2019-05-06 · No fix listed CWE-79
Priority LOW 35
Absolute path traversal vulnerability in htdocs/libraries/image-editor/image-edit.php in ImpressCMS before 1.3.6 allows remote attackers to delete arbitrary files via a full pathname in the image_path parameter in a canc…
CVSS 2.0MEDIUM 6.4· Network · No auth · Interaction — · EPSS 0.0364 · Published 2015-07-01 · Fixed in 1.3.6 CWE-22
Priority LOW 22
Cross-site scripting (XSS) vulnerability in modules/system/admin.php in ImpressCMS 1.3.6.1 allows remote attackers to inject arbitrary web script or HTML via the query parameter in a listimg action.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01012 · Published 2014-06-11 · No fix listed CWE-79
Priority LOW 30
Directory traversal vulnerability in edituser.php in ImpressCMS 1.2.x before 1.2.7 Final and 1.3.x before 1.3.1 Final allows remote authenticated users to include and execute arbitrary local files via a ..
CVSS 2.0MEDIUM 6.0· Network · Low privileges · Interaction — · EPSS 0.01518 · Published 2012-10-06 · No fix listed CWE-22
Priority LOW 23
Multiple cross-site scripting (XSS) vulnerabilities in ImpressCMS 1.2.x before 1.2.7 Final and 1.3.x before 1.3.1 Final allow remote attackers to inject arbitrary web script or HTML via the PATH_INFO to (1) notifications…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01685 · Published 2012-10-06 · No fix listed CWE-79
Priority LOW 22
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the qu…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01085 · Published 2010-12-29 · Fixed in 1.2.4 CWE-79
Priority LOW 35
SQL injection vulnerability in ImpressCMS before 1.2.3 RC2 allows remote attackers to execute arbitrary SQL commands via unspecified vectors.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01063 · Published 2010-11-16 · No fix listed CWE-89
Priority LOW 22
Cross-site scripting (XSS) vulnerability in the userranks feature in modules/system/admin.php in ImpressCMS 1.0.2 final allows remote attackers to inject arbitrary web script or HTML via the rank_title parameter.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01033 · Published 2009-03-02 · No fix listed CWE-79
Priority LOW 33
Session fixation vulnerability in Social ImpressCMS before 1.1.1 RC1 allows remote attackers to hijack web sessions by setting the PHPSESSID parameter.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.01524 · Published 2009-01-23 · No fix listed CWE-287
Priority MEDIUM 46
Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and "a few files."
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.01446 · Published 2008-08-04 · No fix listed