Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

130 records

Priority MEDIUM 41

A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.01098 Published 2025-06-26 No fix listed CWE-78
Priority LOW 24

In versions of the PEADM Forge Module prior to 3.24.0 a security misconfiguration was discovered.

CVSS 4.0MEDIUM 5.4 Local High privileges User interaction EPSS 0.00165 Published 2024-09-27 Fixed in 3.24.0 CWE-295
Priority MEDIUM 43

Versions of Puppet Enterprise prior to 2021.7.6 and 2023.5 contain a flaw which results in broken session management for SAML implementations.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00496 Published 2023-11-07 Fixed in 2021.7.6, 2023.5 CWE-384
Priority MEDIUM 42

In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00447 Published 2023-10-06 Fixed in 3.27.4 CWE-269
Priority LOW 33

For certificates that utilize the auto-renew feature in Puppet Server, a flaw exists which prevents the certificates from being revoked.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00476 Published 2023-10-03 No fix listed CWE-404
Priority LOW 30

A Regular Expression Denial of Service (ReDoS) issue was discovered in Puppet Server 7.9.2 certificate validation.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00437 Published 2023-05-04 Fixed in 2021.7.3, 2023.1.0 +2 CWE-1333
TI-2022-03026 CVE-2022-3276 · GHSA-6wx8-c453-jp55

Puppetlabs-mysql Command Injection

Priority MEDIUM 41

Command injection is possible in the puppetlabs-mysql module prior to version 13.0.0.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01686 Published 2022-10-07 Fixed in 13.0.0 CWE-78
Priority MEDIUM 47

Command injection is possible in the puppetlabs-apt module prior to version 9.0.0.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.02368 Published 2022-10-07 Fixed in 9.0.0 CWE-78
Priority LOW 20

Puppet Bolt prior to version 3.24.0 will print sensitive parameters when planning a run resulting in them potentially being logged when run programmatically, such as via Puppet Enterprise.

CVSS 3.1MEDIUM 4.1 Network Low privileges User interaction EPSS 0.00537 Published 2022-07-19 No fix listed CWE-200
Priority MEDIUM 44

In certain situations it is possible for an unmanaged rule to exist on the target system that has the same comment as the rule specified in the manifest.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00918 Published 2022-03-02 Partial fix · 3.4.0 CWE-1289
Priority LOW 24

A flaw was discovered in bolt-server and ace where running a task with sensitive parameters results in those sensitive parameters being logged when they should not be.

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.00916 Published 2021-09-07 No fix listed CWE-532
Priority LOW 34

The mechanism which performs certificate validation was discovered to have a flaw that resulted in certificates signed by an internal certificate authority to not be properly validated.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00541 Published 2021-08-30 No fix listed CWE-295
TI-2021-08594 CVE-2021-27021 · GHSA-j664-pgf6-rhhh

SQL injection in Puppet DB

Priority MEDIUM 41

A flaw was discovered in Puppet DB, this flaw results in an escalation of privileges which allows the user to delete tables via an SQL query.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01262 Published 2021-07-20 No fix listed CWE-1027
Priority LOW 35

In Continuous Delivery for Puppet Enterprise (CD4PE) before 3.4.0, changes to resources or classes containing Sensitive parameters can result in the Sensitive parameters ending up in the impact analysis report.

CVSS 3.1HIGH 7.7 Network Low privileges No interaction EPSS 0.00859 Published 2020-03-26 No fix listed CWE-200
TI-2020-06423 CVE-2020-7942 · GHSA-gqvf-892r-vjm5

Improper certificate validation in Puppet

Priority LOW 30

Previously, Puppet operated on a model that a node with a valid certificate was entitled to all information in the system and that a compromised certificate allowed access to everything in the infrastructure.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00801 Published 2020-02-19 Partial fix · 5.5.19, 6.13.0 CWE-295
Load more