Priority LOW 29
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SupportCandy allows Stored XSS.This issue affects SupportCandy: from n/a through 3.2.3.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.0032 · Published 2024-03-21 · No fix listed CWE-79
Priority HIGH 67
The SupportCandy WordPress plugin before 3.1.7 does not properly sanitise and escape the agents[] parameter in the set_add_agent_leaves AJAX function before using it in a SQL statement, leading to a SQL injection exploit…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.0085 · Published 2023-06-19 · Fixed in 3.1.7
Priority HIGH 73
The SupportCandy WordPress plugin before 3.1.7 does not properly sanitise and escape the `id` parameter for an Agent in the REST API before using it in an SQL statement, leading to an SQL Injection exploitable by users w…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01203 · Published 2023-06-19 · Fixed in 3.1.7
Priority HIGH 82
The SupportCandy WordPress plugin before 3.1.5 does not validate and escape user input before using it in an SQL statement, which could allow unauthenticated attackers to perform SQL injection attacks
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.40586 · Published 2023-05-02 · Fixed in 3.1.5 CWE-89
Priority LOW 25
The SupportCandy WordPress plugin before 2.2.7 does not validate and escape the page attribute of its shortcode, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00604 · Published 2022-02-07 · Fixed in 2.2.7 CWE-79
Priority LOW 39
The SupportCandy WordPress plugin before 2.2.7 does not have CSRF check in the wpsc_tickets AJAX action, nor has any sanitisation or escaping in some of the filter fields which could allow attackers to make a logged in u…
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00612 · Published 2022-02-07 · Fixed in 2.2.7 CWE-352
Priority LOW 30
The SupportCandy WordPress plugin before 2.2.7 does not sanitise and escape the query string before outputting it back in pages with the [wpsc_create_ticket] shortcode embed, leading to a Reflected Cross-Site Scripting i…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01345 · Published 2022-02-07 · Fixed in 2.2.7 CWE-79
Priority LOW 29
The SupportCandy WordPress plugin before 2.2.7 does not have CRSF check in its wpsc_tickets AJAX action, which could allow attackers to make a logged in admin call it and delete arbitrary tickets via the set_delete_perma…
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00531 · Published 2022-02-07 · Fixed in 2.2.7 CWE-352
Priority LOW 35
The SupportCandy WordPress plugin before 2.2.5 does not have authorisation and CSRF checks in its wpsc_tickets AJAX action, which could allow unauthenticated users to call it and delete arbitrary tickets via the set_dele…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0124 · Published 2022-02-07 · Fixed in 2.2.5 CWE-862
Priority MEDIUM 53
An Unrestricted File Upload Vulnerability in the SupportCandy plugin through 2.0.0 for WordPress allows remote attackers to execute arbitrary code by uploading a file with an executable extension.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.08762 · Published 2019-04-18 · No fix listed CWE-434