Improper handling of exceptional conditions in simplesamlphp
Priority LOW 34CWE-755Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
Why it matters now
EPSS 0.00744 54th percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.8.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| simplesamlphp | simplesamlphp | 1.13.1-2 | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | before 1.8.1 | 1.8.1 | Patch available | GHSA-5fj7-f8x3-q2mc |
- simplesamlphp Vendorsimplesamlphp Affected 1.13.1-2 Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected before 1.8.1 Fixed in 1.8.1 Patch available GHSA-5fj7-f8x3-q2mc
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | 1.6.0 to before 1.6.3; 1.8.0 to before 1.8.2 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions 1.6.0 to before 1.6.3; 1.8.0 to before 1.8.2 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-5fj7-f8x3-q2mc simplesamlphp/simplesamlphp (Packagist) Fixed in 1.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4625
- 2026-10-03 Alias added: GHSA-5fj7-f8x3-q2mc
References
Advisory 3
Other 4
- https://github.com/simplesamlphp/simplesamlphp
- https://github.com/simplesamlphp/simplesamlphp/blob/b3059c51a915910c6631fb2ee597c0fb6ad9162b/docs/simplesamlphp-changelog-1.x.md?plain=1#L1624
- https://secure1.securityspace.com/smysecure/catid.html?in=DSA%202330-1
- https://www.mageni.net/vulnerability/debian-security-advisory-dsa-2330-1-simplesamlphp-70545
More Simplesamlphp vulnerabilities
- TI-2018-04801 The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which… CVSS 3.0CRITICAL 9.8
- TI-2017-09530 The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and… CVSS 3.0CRITICAL 9.8
- TI-2017-09535 SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive… CVSS 3.0CRITICAL 9.8
- TI-2016-07944 The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and… CVSS 3.0CRITICAL 9.1
- TI-2019-02593 Improper signature verification in Rob Richards XmlSecLibs CVSS 3.1HIGH 8.8
- TI-2018-05557 HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect… CVSS 3.0HIGH 8.1
Sources
- CVE-2011-4625 · CVE Program
- CVE-2011-4625 · NVD
- FIRST EPSS
- GHSA-5fj7-f8x3-q2mc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences