Read the docs

simplesamlphp

Records38All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical4CVSS 9.0–10.0
CVSS high17CVSS 7.0–8.9

Exploited now

simplesamlphp records in CISA KEV

No simplesamlphp vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

24 records in Simplesamlphp · all components

Priority MEDIUM 46

The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by l…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.02133 Published 2017-09-01 Fixed in 1.14.14 CWE-384
Priority MEDIUM 45

SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive information, gain unauthorized access, or have unspecified other impacts by leveraging incorrect persistent NameID generation when an Identity…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01656 Published 2017-09-01 Fixed in 1.14.11 CWE-384
Priority MEDIUM 44

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML respons…

CVSS 3.0CRITICAL 9.1 Network No auth No interaction EPSS 0.02413 Published 2017-02-16 Fixed in 1.10.3, 1.8.1 +2 CWE-399
Priority MEDIUM 43

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate o…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.02988 Published 2019-11-07 Fixed in 3.0.4, 2.1.1 CWE-347
Priority LOW 38

HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forc…

CVSS 3.0HIGH 8.1 Network No auth No interaction EPSS 0.01189 Published 2018-03-05 Fixed in 1.10.6, 2.3.8 +1 CWE-347
Priority LOW 36

The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Iden…

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.0145 Published 2018-03-05 Fixed in 1.10.5, 2.3.7 +1 CWE-347
Priority LOW 34

simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00744 Published 2019-11-06 Fixed in 1.8.1 CWE-755
Priority LOW 29

The (1) Htpasswd authentication source in the authcrypt module and (2) SimpleSAML_Session class in SimpleSAMLphp 1.14.11 and earlier allow remote attackers to conduct timing side-channel attacks by leveraging use of the…

CVSS 3.0MEDIUM 5.9 Network No auth No interaction EPSS 0.01459 Published 2017-09-01 Fixed in 1.15.0-rc1 CWE-200
Priority LOW 28

SimpleSAMLphp 1.14.12 and earlier make it easier for man-in-the-middle attackers to obtain sensitive information by leveraging use of the aesEncrypt and aesDecrypt methods in the SimpleSAML/Utils/Crypto class to protect…

CVSS 3.0MEDIUM 5.9 Network No auth No interaction EPSS 0.00875 Published 2017-09-01 Fixed in 1.14.13 CWE-200
Priority LOW 27

The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the firs…

CVSS 3.0MEDIUM 5.9 Network No auth No interaction EPSS 0.0049 Published 2017-09-01 Fixed in 1.14.12 CWE-326
TI-2020-04282 CVE-2020-5226 · GHSA-mj9p-v2r8-wf8w

Cross-site scripting in SimpleSAMLphp

Priority LOW 25

Cross-site scripting in SimpleSAMLphp before version 1.18.4.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00544 Published 2020-01-24 Fixed in 1.18.4 CWE-79
Priority LOW 23

Cross-site scripting (XSS) vulnerability in modules/core/www/no_cookie.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the retryURL p…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.01321 Published 2012-01-24 No fix listed CWE-79
Open these records in search →