The sanitycheck module in SimpleSAMLphp before 1.14.1 allows remote attackers to learn…
Priority LOW 27CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The sanitycheck module in SimpleSAMLphp before 1.14.1 allows remote attackers to learn the PHP version on the system via unspecified vectors.
Why it matters now
EPSS 0.01339 71st percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.14.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | before 1.14.1 | 1.14.1 | Patch available | GHSA-9327-mqm6-x97j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected before 1.14.1 Fixed in 1.14.1 Patch available GHSA-9327-mqm6-x97j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | up to 1.14.0 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.14.0 Vulnerable ·simplesamlphp
Remediation
- Fix · GHSA-9327-mqm6-x97j simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3124
- 2026-10-03 Alias added: GHSA-9327-mqm6-x97j
References
More Simplesamlphp vulnerabilities
- TI-2018-04801 The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which… CVSS 3.0CRITICAL 9.8
- TI-2017-09530 The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and… CVSS 3.0CRITICAL 9.8
- TI-2017-09535 SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive… CVSS 3.0CRITICAL 9.8
- TI-2016-07944 The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and… CVSS 3.0CRITICAL 9.1
- TI-2019-02593 Improper signature verification in Rob Richards XmlSecLibs CVSS 3.1HIGH 8.8
- TI-2018-05557 HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect… CVSS 3.0HIGH 8.1
Sources
- CVE-2016-3124 · CVE Program
- CVE-2016-3124 · NVD
- FIRST EPSS
- GHSA-9327-mqm6-x97j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences