Incorrect permission assignment in Drupal Core
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | Drupal 7.x versions before 7.57 | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 7.0 to before 7.57 | 7.57 | Patch available | GHSA-66mv-q8r2-hj8w |
| — | drupal/drupal (Packagist) | 7.0 to before 7.57 | 7.57 | Patch available | GHSA-66mv-q8r2-hj8w |
- Drupal Core VendorDrupal Affected Drupal 7.x versions before 7.57 Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 7.0 to before 7.57 Fixed in 7.57 Patch available GHSA-66mv-q8r2-hj8w
- drupal/drupal (Packagist) Vendor— Affected 7.0 to before 7.57 Fixed in 7.57 Patch available GHSA-66mv-q8r2-hj8w
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0 to before 7.57 | Vulnerable | Drupal |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.57 Vulnerable ·Drupal
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-66mv-q8r2-hj8w drupal/core (Packagist) Fixed in 7.57 Advisory →
- Fix · GHSA-66mv-q8r2-hj8w drupal/drupal (Packagist) Fixed in 7.57 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Drupal.org Drupal Core — DSA-4123
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2017-04655 Cross-site scripting in Drupal CorePriority LOW 30
- TI-2017-04653 Cross-site scripting in Drupal CorePriority LOW 30
- TI-2017-04658 Open redirect in Drupal CorePriority LOW 24
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6928
- 2026-10-03 Alias added: GHSA-66mv-q8r2-hj8w
References
Advisory 4
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2017-6928 · CVE Program
- CVE-2017-6928 · NVD
- FIRST EPSS
- GHSA-66mv-q8r2-hj8w · GitHub Advisory Database · CC BY 4.0
- CVE-2017-6928 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences