Cross-site scripting in Drupal Core
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 7.x versions before 7.57 | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 7.0 to before 7.57 | 7.57 | Patch available | GHSA-5vpr-v24w-mmjj |
| — | drupal/core (Packagist) | 8.0 to before 8.4.0 | 8.4.0 | Patch available | GHSA-5vpr-v24w-mmjj |
| — | drupal/drupal (Packagist) | 8.0 to before 8.4.0 | 8.4.0 | Patch available | GHSA-5vpr-v24w-mmjj |
| — | drupal/drupal (Packagist) | 7.0 to before 7.57 | 7.57 | Patch available | GHSA-5vpr-v24w-mmjj |
- Drupal Core VendorDrupal Affected 7.x versions before 7.57 Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 7.0 to before 7.57 Fixed in 7.57 Patch available GHSA-5vpr-v24w-mmjj
- drupal/core (Packagist) Vendor— Affected 8.0 to before 8.4.0 Fixed in 8.4.0 Patch available GHSA-5vpr-v24w-mmjj
- drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.4.0 Fixed in 8.4.0 Patch available GHSA-5vpr-v24w-mmjj
- drupal/drupal (Packagist) Vendor— Affected 7.0 to before 7.57 Fixed in 7.57 Patch available GHSA-5vpr-v24w-mmjj
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0 to before 7.57; 8.0.0 to before 8.4.0 | Vulnerable | Drupal |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.57; 8.0.0 to before 8.4.0 Vulnerable ·Drupal
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-5vpr-v24w-mmjj drupal/core (Packagist) Fixed in 7.57 Advisory →
- Fix · GHSA-5vpr-v24w-mmjj drupal/core (Packagist) Fixed in 8.4.0 Advisory →
- Fix · GHSA-5vpr-v24w-mmjj drupal/drupal (Packagist) Fixed in 8.4.0 Advisory →
- Fix · GHSA-5vpr-v24w-mmjj drupal/drupal (Packagist) Fixed in 7.57 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Drupal.org Drupal Core — DSA-4123
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2017-04653 Cross-site scripting in Drupal CorePriority LOW 30
- TI-2017-04654 Incorrect permission assignment in Drupal CorePriority LOW 26
- TI-2017-04658 Open redirect in Drupal CorePriority LOW 24
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6929
- 2026-10-03 Alias added: GHSA-5vpr-v24w-mmjj
References
Advisory 3
Other 4
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2017-6929 · CVE Program
- CVE-2017-6929 · NVD
- FIRST EPSS
- GHSA-5vpr-v24w-mmjj · GitHub Advisory Database · CC BY 4.0
- CVE-2017-6929 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences