The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through…
Priority LOW 27CWE-326Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-326.
Summary
The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).
Why it matters now
EPSS 0.0049 42nd percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.14.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | 1.14.0 to before 1.14.12 | 1.14.12 | Patch available | GHSA-ww3w-592j-5qrw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected 1.14.0 to before 1.14.12 Fixed in 1.14.12 Patch available GHSA-ww3w-592j-5qrw
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.0:*:*:*:*:*:*:* | 1.14.0 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.1:*:*:*:*:*:*:* | 1.14.1 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.2:*:*:*:*:*:*:* | 1.14.2 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.3:*:*:*:*:*:*:* | 1.14.3 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.4:*:*:*:*:*:*:* | 1.14.4 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.5:*:*:*:*:*:*:* | 1.14.5 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.6:*:*:*:*:*:*:* | 1.14.6 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.7:*:*:*:*:*:*:* | 1.14.7 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.8:*:*:*:*:*:*:* | 1.14.8 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.9:*:*:*:*:*:*:* | 1.14.9 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.0:*:*:*:*:*:*:* Versions 1.14.0 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.1:*:*:*:*:*:*:* Versions 1.14.1 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.2:*:*:*:*:*:*:* Versions 1.14.2 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.3:*:*:*:*:*:*:* Versions 1.14.3 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.4:*:*:*:*:*:*:* Versions 1.14.4 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.5:*:*:*:*:*:*:* Versions 1.14.5 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.6:*:*:*:*:*:*:* Versions 1.14.6 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.7:*:*:*:*:*:*:* Versions 1.14.7 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.8:*:*:*:*:*:*:* Versions 1.14.8 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.9:*:*:*:*:*:*:* Versions 1.14.9 Vulnerable ·simplesamlphp
Show 2 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.10:*:*:*:*:*:*:* | 1.14.10 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.11:*:*:*:*:*:*:* | 1.14.11 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.10:*:*:*:*:*:*:* Versions 1.14.10 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.14.11:*:*:*:*:*:*:* Versions 1.14.11 Vulnerable ·simplesamlphp
Remediation
- Fix · GHSA-ww3w-592j-5qrw simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12871
- 2026-10-03 Alias added: GHSA-ww3w-592j-5qrw
References
Patch 2
More Simplesamlphp vulnerabilities
- TI-2018-04801 The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which… CVSS 3.0CRITICAL 9.8
- TI-2017-09530 The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and… CVSS 3.0CRITICAL 9.8
- TI-2017-09535 SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive… CVSS 3.0CRITICAL 9.8
- TI-2016-07944 The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and… CVSS 3.0CRITICAL 9.1
- TI-2019-02593 Improper signature verification in Rob Richards XmlSecLibs CVSS 3.1HIGH 8.8
- TI-2018-05557 HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect… CVSS 3.0HIGH 8.1
Sources
- CVE-2017-12871 · CVE Program
- CVE-2017-12871 · NVD
- FIRST EPSS
- GHSA-ww3w-592j-5qrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences