The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/saml2 (Packagist) | before 1.10.5 | 1.10.5 | Patch available | GHSA-923w-2xv2-7pr8 |
| — | simplesamlphp/saml2 (Packagist) | 2.0 to before 2.3.7 | 2.3.7 | Patch available | GHSA-923w-2xv2-7pr8 |
| — | simplesamlphp/saml2 (Packagist) | 3.0 to before 3.1.3 | 3.1.3 | Patch available | GHSA-923w-2xv2-7pr8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/saml2 (Packagist) Vendor— Affected before 1.10.5 Fixed in 1.10.5 Patch available GHSA-923w-2xv2-7pr8
- simplesamlphp/saml2 (Packagist) Vendor— Affected 2.0 to before 2.3.7 Fixed in 2.3.7 Patch available GHSA-923w-2xv2-7pr8
- simplesamlphp/saml2 (Packagist) Vendor— Affected 3.0 to before 3.1.3 Fixed in 3.1.3 Patch available GHSA-923w-2xv2-7pr8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | before 1.15.3 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions before 1.15.3 Vulnerable ·simplesamlphp
Remediation
- Fix · GHSA-923w-2xv2-7pr8 simplesamlphp/saml2 (Packagist) Fixed in 1.10.5 Advisory →
- Fix · GHSA-923w-2xv2-7pr8 simplesamlphp/saml2 (Packagist) Fixed in 2.3.7 Advisory →
- Fix · GHSA-923w-2xv2-7pr8 simplesamlphp/saml2 (Packagist) Fixed in 3.1.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7644
- 2026-10-03 Alias added: GHSA-923w-2xv2-7pr8
References
More Simplesamlphp vulnerabilities
- TI-2018-04801 The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which… CVSS 3.0CRITICAL 9.8
- TI-2017-09530 The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and… CVSS 3.0CRITICAL 9.8
- TI-2017-09535 SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive… CVSS 3.0CRITICAL 9.8
- TI-2016-07944 The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and… CVSS 3.0CRITICAL 9.1
- TI-2019-02593 Improper signature verification in Rob Richards XmlSecLibs CVSS 3.1HIGH 8.8
- TI-2018-05557 HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect… CVSS 3.0HIGH 8.1
Sources
- CVE-2018-7644 · CVE Program
- CVE-2018-7644 · NVD
- FIRST EPSS
- GHSA-923w-2xv2-7pr8 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-7644 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences